summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-12-26 16:51:10 -0500
committerAnthony G. Basile <blueness@gentoo.org>2017-12-26 16:51:10 -0500
commit3339879052de5408831ed4e3b6859c635b968e09 (patch)
tree08ab2da078650e3675fd3d2adf6b0e74a7401ead /sys-devel/gcc/gcc-5.4.0-r4.ebuild
parentnet-analyzer/wireshark: stable 2.4.3 for ia64, bug #639686 (diff)
downloadgentoo-3339879052de5408831ed4e3b6859c635b968e09.tar.gz
gentoo-3339879052de5408831ed4e3b6859c635b968e09.tar.bz2
gentoo-3339879052de5408831ed4e3b6859c635b968e09.zip
sys-devel/gcc: bump 4.7.4, 4.8.5, 5.4.0-r4 to EAPI=5, bug #642316
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Signed-off-by: Matthias Maier <tamiko@gentoo.org> Package-Manager: Portage-2.3.13, Repoman-2.3.3 RepoMan-Options: --force
Diffstat (limited to 'sys-devel/gcc/gcc-5.4.0-r4.ebuild')
-rw-r--r--sys-devel/gcc/gcc-5.4.0-r4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-5.4.0-r4.ebuild b/sys-devel/gcc/gcc-5.4.0-r4.ebuild
new file mode 100644
index 000000000000..a1c972f7c873
--- /dev/null
+++ b/sys-devel/gcc/gcc-5.4.0-r4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.7"
+UCLIBC_VER="1.0"
+
+# Hardened gcc 4 stuff
+PIE_VER="0.6.5"
+SPECS_VER="0.2.0"
+SPECS_GCC_VER="4.4.3"
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+PIE_GLIBC_STABLE="x86 amd64 mips ppc ppc64 arm ia64"
+PIE_UCLIBC_STABLE="x86 arm amd64 mips ppc ppc64"
+SSP_STABLE="amd64 x86 mips ppc ppc64 arm"
+# uclibc need tls and nptl support for SSP support
+# uclibc need to be >= 0.9.33
+SSP_UCLIBC_STABLE="x86 amd64 mips ppc ppc64 arm"
+#end Hardened stuff
+
+inherit toolchain
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_prepare() {
+ if has_version '<sys-libs/glibc-2.12' ; then
+ ewarn "Your host glibc is too old; disabling automatic fortify."
+ ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
+ EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+ fi
+ is_crosscompile && EPATCH_EXCLUDE+=" 05_all_gcc-spec-env.patch"
+
+ toolchain_src_prepare
+}