summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-10-27 10:23:45 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-10-27 12:46:08 +0100
commit7f16eb5b72bb49fa1dbdedd08ee85b95eaf67cdd (patch)
treee918bc2c86510667462a7eeeb450f7aa42b72864 /sys-devel/gcc/gcc-6.4.0-r5.ebuild
parentsys-devel/gcc: cut 1.8 patchset for 7.3.0 (diff)
downloadgentoo-7f16eb5b72bb49fa1dbdedd08ee85b95eaf67cdd.tar.gz
gentoo-7f16eb5b72bb49fa1dbdedd08ee85b95eaf67cdd.tar.bz2
gentoo-7f16eb5b72bb49fa1dbdedd08ee85b95eaf67cdd.zip
sys-devel/gcc: cut 1.8 patchset for 6.4.0
Eight new patches: + 103_all_remove-lieee.patch: drop assumed -lieee from -mieee-fp + 104_all_libgfortran-Werror.patch: + 105_all_libgomp-Werror.patch + 106_all_libitm-Werror.patch + 107_all_libatomic-Werror.patch + 108_all_libbacktrace-Werror.patch + 109_all_libsanitizer-libbacktrace-Werror.patch: pull in all -Werror patches from 8.2.0 + 110_all_libstdcxx-no-vtv.patch: drop libvtv RPATH from libstdc++ Bug: https://bugs.gentoo.org/667104 Bug: https://bugs.gentoo.org/475350 Bug: https://bugs.gentoo.org/229059 Bug: http://gcc.gnu.org/PR38436 Bug: https://bugs.gentoo.org/433435 Bug: http://gcc.gnu.org/PR54724 Bug: https://bugs.gentoo.org/582524 Bug: https://gcc.gnu.org/PR85884 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sys-devel/gcc/gcc-6.4.0-r5.ebuild')
-rw-r--r--sys-devel/gcc/gcc-6.4.0-r5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-6.4.0-r5.ebuild b/sys-devel/gcc/gcc-6.4.0-r5.ebuild
new file mode 100644
index 000000000000..8f8f11741c12
--- /dev/null
+++ b/sys-devel/gcc/gcc-6.4.0-r5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.8"
+UCLIBC_VER="1.0"
+
+inherit toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.13 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
+fi
+
+src_prepare() {
+ toolchain_src_prepare
+}