summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-01-06 19:54:31 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-01-06 19:55:00 +0000
commitecb2d0bf2d0195efe753abb3f32e7ee1599c12ce (patch)
treec25921829f462b0a55e342d9b414c09065dd8a5a /sys-devel/gcc/gcc-7.2.0-r1.ebuild
parentdev-python/waitress: stable 1.0.2 for hppa, bug #639114 (diff)
downloadgentoo-ecb2d0bf2d0195efe753abb3f32e7ee1599c12ce.tar.gz
gentoo-ecb2d0bf2d0195efe753abb3f32e7ee1599c12ce.tar.bz2
gentoo-ecb2d0bf2d0195efe753abb3f32e7ee1599c12ce.zip
sys-devel/gcc: bump 6.4.0 and 7.2.0 patchsets, bug #641474
Two new patches for a single issue: - 95_all_static_override_pie.patch - 96_all_powerpc_pie.patch First fixes -static handling for --default-pie compiler. Second fixes to use proper startup files for --default-pie on powerpc. This should unbreak 17.0 profiles at least for powerpc. Dropped keywords until minimal testing is done for other arches. Bug: https://bugs.gentoo.org/641474 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-devel/gcc/gcc-7.2.0-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-7.2.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-7.2.0-r1.ebuild b/sys-devel/gcc/gcc-7.2.0-r1.ebuild
new file mode 100644
index 000000000000..881f171fff72
--- /dev/null
+++ b/sys-devel/gcc/gcc-7.2.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.1"
+#UCLIBC_VER="1.0"
+
+inherit toolchain
+
+# unkeyworded for testing bug #641474
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.13 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
+fi
+
+src_prepare() {
+ toolchain_src_prepare
+}