summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-06-01 09:10:24 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-06-01 09:10:24 +0100
commit7b05c25d58e86b89acaaf634b4e1b1f77b5ac54a (patch)
treec906b9999b9825eb052c26e002f92c0245198fc0 /sys-devel/gcc/gcc-7.4.0-r2.ebuild
parentsys-devel/gcc: 9.1.0: cut 1.1 patchset (diff)
downloadgentoo-7b05c25d58e86b89acaaf634b4e1b1f77b5ac54a.tar.gz
gentoo-7b05c25d58e86b89acaaf634b4e1b1f77b5ac54a.tar.bz2
gentoo-7b05c25d58e86b89acaaf634b4e1b1f77b5ac54a.zip
sys-devel/gcc: 7.4.0: cut 1.3 patchset
Single new patch to backport PGO fix. Bug: https://bugs.gentoo.org/677724 Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gcc/gcc-7.4.0-r2.ebuild')
-rw-r--r--sys-devel/gcc/gcc-7.4.0-r2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-7.4.0-r2.ebuild b/sys-devel/gcc/gcc-7.4.0-r2.ebuild
new file mode 100644
index 000000000000..9f0be86c0d6c
--- /dev/null
+++ b/sys-devel/gcc/gcc-7.4.0-r2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.3"
+
+inherit toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.13 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
+fi