summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-12-26 19:37:14 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-12-26 19:39:59 +0000
commitd27b9469785e09efe5e808af0dfbf7eebdeaf627 (patch)
tree10674be78a368711ff726273868df68d7ce8006c /sys-devel/gcc/gcc-8.2.0-r6.ebuild
parentwww-client/chromium: depend on virtual/jre (diff)
downloadgentoo-d27b9469785e09efe5e808af0dfbf7eebdeaf627.tar.gz
gentoo-d27b9469785e09efe5e808af0dfbf7eebdeaf627.tar.bz2
gentoo-d27b9469785e09efe5e808af0dfbf7eebdeaf627.zip
sys-devel/gcc: bump up to 1.7 patchset
Two new patches: + 114_all_kr-decl-PR88214.patch: ICE on k&r declarations + 115_all_avx2-SIGSEGV-PR86871.patch: ICE in vectorizer Bug: https://bugs.gentoo.org/672032 Bug: https://bugs.gentoo.org/657060 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gcc/gcc-8.2.0-r6.ebuild')
-rw-r--r--sys-devel/gcc/gcc-8.2.0-r6.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-8.2.0-r6.ebuild b/sys-devel/gcc/gcc-8.2.0-r6.ebuild
new file mode 100644
index 000000000000..0f298964ae7f
--- /dev/null
+++ b/sys-devel/gcc/gcc-8.2.0-r6.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.7"
+#UCLIBC_VER="1.0"
+
+inherit toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.13 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
+fi