summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-06-01 09:03:25 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-06-01 09:03:25 +0100
commit93052fb8b1eef5f3c61800eaa8d8acc858a349b0 (patch)
tree225bbaff8e48b1fa395887513bd0a7bcfa63bb0c /sys-devel/gcc/gcc-9.1.0-r1.ebuild
parentdev-ruby/ruby-gnome2: add 3.3.6 (diff)
downloadgentoo-93052fb8b1eef5f3c61800eaa8d8acc858a349b0.tar.gz
gentoo-93052fb8b1eef5f3c61800eaa8d8acc858a349b0.tar.bz2
gentoo-93052fb8b1eef5f3c61800eaa8d8acc858a349b0.zip
sys-devel/gcc: 9.1.0: cut 1.1 patchset
Three new patches: 26_all_ipa-incomplete.patch: fix ICE on pcsx2 package 27_all_es-po.patch: fix ICE on es lcoales 28_all_disable-riscv32-ABIs.patch: disable unconditional riscv32 ABIs Bug: https://gcc.gnu.org/PR90303 Closes: https://bugs.gentoo.org/686930 Bug: https://gcc.gnu.org/PR90528 Closes: https://bugs.gentoo.org/686076 Bug: https://gcc.gnu.org/PR90419 Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gcc/gcc-9.1.0-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-9.1.0-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-9.1.0-r1.ebuild b/sys-devel/gcc/gcc-9.1.0-r1.ebuild
new file mode 100644
index 000000000000..73c93d32ff1b
--- /dev/null
+++ b/sys-devel/gcc/gcc-9.1.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PATCH_VER="1.1"
+
+inherit toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.13 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
+fi