summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-12-04 16:11:24 +0100
committerFabian Groffen <grobian@gentoo.org>2020-12-04 16:11:41 +0100
commit375f3579a115a14ddbd99aae0302da4d1dec4fea (patch)
tree160303f913ce93e4796f0293dfc06db45053b704 /sys-devel/gdb/gdb-9999.ebuild
parentapp-accessibility/caribou: add py3_8 (diff)
downloadgentoo-375f3579a115a14ddbd99aae0302da4d1dec4fea.tar.gz
gentoo-375f3579a115a14ddbd99aae0302da4d1dec4fea.tar.bz2
gentoo-375f3579a115a14ddbd99aae0302da4d1dec4fea.zip
sys-devel/gdb-10.1: fix compilation on Solaris
- refrain from linking against ancient libtermcap - really use auto-detection on gdbserver with USE=server Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 44bd11b39262..1645237331c0 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -99,6 +99,10 @@ src_prepare() {
strip-linguas -u bfd/po opcodes/po
export CC_FOR_BUILD=$(tc-getBUILD_CC)
+
+ # avoid using ancient termcap from host on Prefix systems
+ sed -i -e 's/termcap tinfow/tinfow/g' \
+ gdb/configure{.ac,} || die
}
gdb_branding() {
@@ -141,10 +145,11 @@ src_configure() {
# gdbserver only works for native targets (CHOST==CTARGET).
# it also doesn't support all targets, so rather than duplicate
# the target list (which changes between versions), use the
- # "auto" value when things are turned on.
- is_cross \
- && myconf+=( --disable-gdbserver ) \
- || myconf+=( $(use_enable server gdbserver auto) )
+ # "auto" value when things are turned on, which is triggered
+ # whenever no --enable or --disable is given
+ if is_cross || use !server ; then
+ myconf+=( --disable-gdbserver )
+ fi
fi
if ! ( use server && ! use client ) ; then