summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <stha09@googlemail.com>2018-02-17 19:38:52 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-02-18 12:08:46 +0000
commit29264a5d156fc35c99c3cfa863ac6992d083f1e2 (patch)
tree96a26f08b2b3a31181505b39d5d2544745130fe3 /sys-devel/gdb
parentapp-misc/pax-utils: adopt an orphan (diff)
downloadgentoo-29264a5d156fc35c99c3cfa863ac6992d083f1e2.tar.gz
gentoo-29264a5d156fc35c99c3cfa863ac6992d083f1e2.tar.bz2
gentoo-29264a5d156fc35c99c3cfa863ac6992d083f1e2.zip
sys-devel/gdb: fix gcore collision on freebsd
Closes: https://bugs.gentoo.org/507456 Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7216
Diffstat (limited to 'sys-devel/gdb')
-rw-r--r--sys-devel/gdb/gdb-8.1.ebuild5
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild7
2 files changed, 11 insertions, 1 deletions
diff --git a/sys-devel/gdb/gdb-8.1.ebuild b/sys-devel/gdb/gdb-8.1.ebuild
index d464d9858286..8ba27771a09d 100644
--- a/sys-devel/gdb/gdb-8.1.ebuild
+++ b/sys-devel/gdb/gdb-8.1.ebuild
@@ -234,6 +234,11 @@ src_install() {
# Remove shared info pages
rm -f "${ED}"/usr/share/info/{annotate,bfd,configure,standards}.info*
+
+ # gcore is part of ubin on freebsd
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ rm "${ED}"/usr/bin/gcore || die
+ fi
}
pkg_postinst() {
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 8ae03593af2f..553005830a8d 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -218,6 +218,11 @@ src_install() {
# Remove shared info pages
rm -f "${ED}"/usr/share/info/{annotate,bfd,configure,standards}.info*
+
+ # gcore is part of ubin on freebsd
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ rm "${ED}"/usr/bin/gcore || die
+ fi
}
pkg_postinst() {