summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-01-03 13:11:28 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-01-03 13:14:42 +0000
commitcef85020eeed3ea2e89aeb0bd78fb4623738bbbf (patch)
tree1f2a8afad6415fba0a90844555b84daefec02f0e /sys-devel/gdb
parentwww-plugins/adobe-flash: Remove last-rited pkg (diff)
downloadgentoo-cef85020eeed3ea2e89aeb0bd78fb4623738bbbf.tar.gz
gentoo-cef85020eeed3ea2e89aeb0bd78fb4623738bbbf.tar.bz2
gentoo-cef85020eeed3ea2e89aeb0bd78fb4623738bbbf.zip
sys-devel/gdb: expliictly disable debuginfod
Fixed-by: Fabian Groffen Reported-by: Jason Cooper Bug: https://bugs.gentoo.org/754753 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gdb')
-rw-r--r--sys-devel/gdb/gdb-10.1.ebuild6
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/sys-devel/gdb/gdb-10.1.ebuild b/sys-devel/gdb/gdb-10.1.ebuild
index 44862575ac40..0d958a65b3c2 100644
--- a/sys-devel/gdb/gdb-10.1.ebuild
+++ b/sys-devel/gdb/gdb-10.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -129,6 +129,10 @@ src_configure() {
--disable-werror
# Disable modules that are in a combined binutils/gdb tree. #490566
--disable-{binutils,etc,gas,gold,gprof,ld}
+
+ # avoid automagic dependency on (currently prefix) systems
+ # systems with debuginfod library, bgu #754753
+ --without-debuginfod
)
local sysroot="${EPREFIX}/usr/${CTARGET}"
is_cross && myconf+=(
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index c423dd7af766..4cb70ba29bec 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -129,6 +129,10 @@ src_configure() {
--disable-werror
# Disable modules that are in a combined binutils/gdb tree. #490566
--disable-{binutils,etc,gas,gold,gprof,ld}
+
+ # avoid automagic dependency on (currently prefix) systems
+ # systems with debuginfod library, bug #754753
+ --without-debuginfod
)
local sysroot="${EPREFIX}/usr/${CTARGET}"
is_cross && myconf+=(