summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucas Yamanishi <lucas.yamanishi@gmail.com>2020-05-26 13:58:23 -0400
committerSam James <sam@gentoo.org>2021-12-21 04:19:18 +0000
commita857ea599201b42ab12a2919badfd7b34997cbbb (patch)
tree4aba15660918c18bf1ba1318d708e1c8ee8fc2a9 /sys-devel/icecream/icecream-1.3.1.ebuild
parentkde-apps/gwenview: fix kipi automagic typo (diff)
downloadgentoo-a857ea599201b42ab12a2919badfd7b34997cbbb.tar.gz
gentoo-a857ea599201b42ab12a2919badfd7b34997cbbb.tar.bz2
gentoo-a857ea599201b42ab12a2919badfd7b34997cbbb.zip
sys-devel/icecream: Bump to 1.3.1, various fixes
* Fixes bug #602492 * Adds systemd support * Installs firewalld service files Bug: https://bugs.gentoo.org/602492 Closes: https://bugs.gentoo.org/527376 Closes: https://bugs.gentoo.org/642674 Closes: https://github.com/gentoo/gentoo/pull/15975 Signed-off-by: Lucas Yamanishi <lucas.yamanishi@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/icecream/icecream-1.3.1.ebuild')
-rw-r--r--sys-devel/icecream/icecream-1.3.1.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/sys-devel/icecream/icecream-1.3.1.ebuild b/sys-devel/icecream/icecream-1.3.1.ebuild
new file mode 100644
index 000000000000..d9443057aaaf
--- /dev/null
+++ b/sys-devel/icecream/icecream-1.3.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd tmpfiles
+
+DESCRIPTION='Distributed compiling of C(++) code across several machines; based on distcc'
+HOMEPAGE='https://github.com/icecc/icecream'
+SRC_URI="https://github.com/icecc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE='GPL-2'
+SLOT='0'
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE='systemd'
+
+DEPEND='
+ acct-user/icecream
+ acct-group/icecream
+ sys-libs/libcap-ng
+ app-text/docbook2X
+ app-arch/zstd
+'
+RDEPEND="
+ ${DEPEND}
+ dev-util/shadowman
+ systemd? ( sys-apps/systemd )
+"
+
+AT_NOELIBTOOLIZE='yes'
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-clang-rewrite-includes \
+ --enable-clang-wrappers \
+ --disable-fast-install
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ if use systemd; then
+ systemd_dounit "${FILESDIR}/iceccd.service"
+ systemd_dounit "${FILESDIR}/icecc-scheduler.service"
+ else
+ newconfd suse/sysconfig.icecream icecream
+ newinitd "${FILESDIR}/icecream.openrc" icecream
+ fi
+
+ keepdir /var/log/icecream
+ fowners icecream:icecream /var/log/icecream
+ fperms 0750 /var/log/icecream
+
+ newtmpfiles "${FILESDIR}/icecream-tmpfiles.conf" icecream.conf
+
+ insinto /etc/logrotate.d
+ newins suse/logrotate icecream
+
+ insinto /etc/firewalld/services
+ doins suse/iceccd.xml
+ doins suse/icecc-scheduler.xml
+
+ insinto /usr/share/shadowman/tools
+ newins - icecc <<<'/usr/libexec/icecc/bin'
+}
+
+pkg_prerm() {
+ if [[ -z ${REPLACED_BY_VERSION} && ${ROOT} == / ]]; then
+ eselect compiler-shadow remove icecc
+ fi
+}
+
+pkg_postinst() {
+ tmpfiles_process icecream.conf
+
+ if [[ ${ROOT} == / ]]; then
+ eselect compiler-shadow update icecc
+ fi
+}