summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-07-23 09:58:59 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-07-23 09:58:59 +0100
commit1d7f0c2d8e67676f950facc1303bab9324cc3670 (patch)
tree51ded1ab32d1ead936426e992f975e179e22a5a4 /sys-devel/kgcc64/kgcc64-10.2.0.ebuild
parentdev-python/importlib_metadata: stable 1.6.1 for hppa, bug #731414 (diff)
downloadgentoo-1d7f0c2d8e67676f950facc1303bab9324cc3670.tar.gz
gentoo-1d7f0c2d8e67676f950facc1303bab9324cc3670.tar.bz2
gentoo-1d7f0c2d8e67676f950facc1303bab9324cc3670.zip
sys-devel/kgcc64: bump up to 10.2.0
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/kgcc64/kgcc64-10.2.0.ebuild')
-rw-r--r--sys-devel/kgcc64/kgcc64-10.2.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-devel/kgcc64/kgcc64-10.2.0.ebuild b/sys-devel/kgcc64/kgcc64-10.2.0.ebuild
new file mode 100644
index 000000000000..e0c1432958e8
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-10.2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+GCC_TARGET_NO_MULTILIB=true
+
+PATCH_VER="1"
+inherit toolchain
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on hppa and mips; all other archs, refer to bug #228115
+KEYWORDS="~hppa ~mips"
+
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+DEPEND="hppa? ( sys-devel/binutils-hppa64 )"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}