summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-07-23 18:37:53 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-07-23 18:38:40 +0100
commiteac700b2f29c7a9389bb4084624d8df9e4418b26 (patch)
treebec3c42eae693685040bb40445e300f83f4488b8 /sys-devel/kgcc64/kgcc64-9.3.0-r2.ebuild
parentmedia-gfx/exact-image: fix calling g++ directly (diff)
downloadgentoo-eac700b2f29c7a9389bb4084624d8df9e4418b26.tar.gz
gentoo-eac700b2f29c7a9389bb4084624d8df9e4418b26.tar.bz2
gentoo-eac700b2f29c7a9389bb4084624d8df9e4418b26.zip
sys-devel/kgcc64: sync versions and patches with sys-deve/gcc
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/kgcc64/kgcc64-9.3.0-r2.ebuild')
-rw-r--r--sys-devel/kgcc64/kgcc64-9.3.0-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-devel/kgcc64/kgcc64-9.3.0-r2.ebuild b/sys-devel/kgcc64/kgcc64-9.3.0-r2.ebuild
new file mode 100644
index 000000000000..c52a4bfafc3e
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-9.3.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+GCC_TARGET_NO_MULTILIB=true
+
+PATCH_VER="3"
+inherit toolchain
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on hppa and mips; all other archs, refer to bug #228115
+KEYWORDS="~hppa ~mips"
+
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+DEPEND="hppa? ( sys-devel/binutils-hppa64 )"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}