summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-12-09 14:52:27 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-12-09 14:53:40 +0100
commite5719bec93136e71cc64b6357d24f1199df33a8e (patch)
tree806275e34a349b027aaa3c35ca43ae89953c2063 /sys-devel/libtool/libtool-2.4.4.ebuild
parentsys-devel/libtool: Stable for amd64 and x86 (bug #601098). (diff)
downloadgentoo-e5719bec93136e71cc64b6357d24f1199df33a8e.tar.gz
gentoo-e5719bec93136e71cc64b6357d24f1199df33a8e.tar.bz2
gentoo-e5719bec93136e71cc64b6357d24f1199df33a8e.zip
sys-devel/libtool: Removed old.
Package-Manager: portage-2.3.3
Diffstat (limited to 'sys-devel/libtool/libtool-2.4.4.ebuild')
-rw-r--r--sys-devel/libtool/libtool-2.4.4.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/sys-devel/libtool/libtool-2.4.4.ebuild b/sys-devel/libtool/libtool-2.4.4.ebuild
deleted file mode 100644
index 71a9b47a26fd..000000000000
--- a/sys-devel/libtool/libtool-2.4.4.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-LIBTOOLIZE="true" #225559
-WANT_LIBTOOL="none"
-inherit eutils autotools multilib unpacker
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
- http://git.savannah.gnu.org/r/${PN}.git"
- inherit git-2
-else
- SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-fi
-
-DESCRIPTION="A shared library tool for developers"
-HOMEPAGE="https://www.gnu.org/software/libtool/"
-
-LICENSE="GPL-2"
-SLOT="2"
-IUSE="vanilla"
-
-# Pull in libltdl directly until we convert packages to the new dep.
-RDEPEND="sys-devel/gnuconfig
- >=sys-devel/autoconf-2.69
- >=sys-devel/automake-1.13
- dev-libs/libltdl:0"
-DEPEND="${RDEPEND}
- app-arch/xz-utils"
-[[ ${PV} == "9999" ]] && DEPEND+=" sys-apps/help2man"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git-2_src_unpack
- cd "${S}"
- ./bootstrap || die
- else
- unpacker_src_unpack
- fi
-}
-
-src_prepare() {
- use vanilla && return 0
-
- epatch "${FILESDIR}"/${PN}-2.4.3-use-linux-version-in-fbsd.patch #109105
- pushd libltdl >/dev/null
- AT_NOELIBTOOLIZE=yes eautoreconf
- popd >/dev/null
- AT_NOELIBTOOLIZE=yes eautoreconf
- epunt_cxx
-}
-
-src_configure() {
- # the libtool script uses bash code in it and at configure time, tries
- # to find a bash shell. if /bin/sh is bash, it uses that. this can
- # cause problems for people who switch /bin/sh on the fly to other
- # shells, so just force libtool to use /bin/bash all the time.
- export CONFIG_SHELL=/bin/bash
- ECONF_SOURCE=${S} econf --disable-ltdl-install
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- default
-
- local x
- while read -d $'\0' -r x ; do
- ln -sf "${EPREFIX}"/usr/share/gnuconfig/${x##*/} "${x}" || die
- done < <(find "${ED}" '(' -name config.guess -o -name config.sub ')' -print0)
-}