summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-02 13:47:50 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-03 08:04:03 +0200
commit97344eb19de03e825c7b2b099479eb1e63b96b1b (patch)
tree175288a4c80b0ec0dec5efada8fb77eaa6be6c07 /sys-devel/lld/lld-13.0.0.ebuild
parentdev-ruby/nokogiri: add 1.12.5 (diff)
downloadgentoo-97344eb19de03e825c7b2b099479eb1e63b96b1b.tar.gz
gentoo-97344eb19de03e825c7b2b099479eb1e63b96b1b.tar.bz2
gentoo-97344eb19de03e825c7b2b099479eb1e63b96b1b.zip
sys-devel/lld: Ensure NDEBUG correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/lld/lld-13.0.0.ebuild')
-rw-r--r--sys-devel/lld/lld-13.0.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-devel/lld/lld-13.0.0.ebuild b/sys-devel/lld/lld-13.0.0.ebuild
index 28e940174a88..26c283fd6489 100644
--- a/sys-devel/lld/lld-13.0.0.ebuild
+++ b/sys-devel/lld/lld-13.0.0.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE="test"
+IUSE="debug test"
RESTRICT="!test? ( test )"
RDEPEND="~sys-devel/llvm-${PV}"
@@ -48,6 +48,9 @@ src_unpack() {
}
src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)