summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-21 09:26:56 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-21 09:30:15 +0100
commitfbcd922cdfcd3bad2d1419183f393bb73ef65d86 (patch)
tree5bde442dea03099dbaa3253e7936dfefaf51d5f2 /sys-devel/lld/lld-9.0.1.9999.ebuild
parentsys-devel/clang-common: Remove 9.0.1 RCs and live (diff)
downloadgentoo-fbcd922cdfcd3bad2d1419183f393bb73ef65d86.tar.gz
gentoo-fbcd922cdfcd3bad2d1419183f393bb73ef65d86.tar.bz2
gentoo-fbcd922cdfcd3bad2d1419183f393bb73ef65d86.zip
sys-devel/lld: Remove 9.0.1 RCs and live
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/lld/lld-9.0.1.9999.ebuild')
-rw-r--r--sys-devel/lld/lld-9.0.1.9999.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/sys-devel/lld/lld-9.0.1.9999.ebuild b/sys-devel/lld/lld-9.0.1.9999.ebuild
deleted file mode 100644
index 08b0bcbf80e9..000000000000
--- a/sys-devel/lld/lld-9.0.1.9999.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils llvm llvm.org multiprocessing python-any-r1
-
-DESCRIPTION="The LLVM linker (link editor)"
-HOMEPAGE="https://llvm.org/"
-LLVM_COMPONENTS=( lld )
-LLVM_TEST_COMPONENTS=( llvm/utils/{lit,unittest} )
-llvm.org_set_globals
-
-LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
-SLOT="0"
-KEYWORDS=""
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="~sys-devel/llvm-${PV}"
-DEPEND="${RDEPEND}"
-BDEPEND="test? ( $(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]") )"
-
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
-python_check_deps() {
- has_version -b "dev-python/lit[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- LLVM_MAX_SLOT=${PV%%.*} llvm_pkg_setup
- use test && python-any-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
-
- -DLLVM_INCLUDE_TESTS=$(usex test)
- )
- use test && mycmakeargs+=(
- -DLLVM_BUILD_TESTS=ON
- -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
- -DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
- )
-
- cmake-utils_src_configure
-}
-
-src_test() {
- local -x LIT_PRESERVES_TMP=1
- cmake-utils_src_make check-lld
-}