summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-30 19:07:56 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-15 13:47:23 +0100
commitff80562c7707b0a4d836c0b8b498dfc48cdedb9a (patch)
tree45070467ed84d2899a9213cd42707a14f30ebfb5 /sys-devel/lld/lld-9999.ebuild
parentdev-ml/llvm-ocaml: Fix install against slotted LLVM (diff)
downloadgentoo-ff80562c7707b0a4d836c0b8b498dfc48cdedb9a.tar.gz
gentoo-ff80562c7707b0a4d836c0b8b498dfc48cdedb9a.tar.bz2
gentoo-ff80562c7707b0a4d836c0b8b498dfc48cdedb9a.zip
sys-devel/lld: Support building against slotted LLVM
Diffstat (limited to 'sys-devel/lld/lld-9999.ebuild')
-rw-r--r--sys-devel/lld/lld-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-devel/lld/lld-9999.ebuild b/sys-devel/lld/lld-9999.ebuild
index b4f23d3031e8..b6ef4ad0436e 100644
--- a/sys-devel/lld/lld-9999.ebuild
+++ b/sys-devel/lld/lld-9999.ebuild
@@ -9,7 +9,7 @@ EAPI=6
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils git-r3 python-any-r1
+inherit cmake-utils git-r3 llvm python-any-r1
DESCRIPTION="The LLVM linker (link editor)"
HOMEPAGE="http://llvm.org/"
@@ -34,6 +34,7 @@ python_check_deps() {
}
pkg_setup() {
+ llvm_pkg_setup
use test && python-any-r1_pkg_setup
}
@@ -53,7 +54,6 @@ src_unpack() {
}
src_configure() {
- local libdir=$(get_libdir)
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON