summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-09-08 10:53:35 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-08 19:30:22 +0200
commit5dfebe5f813c2a4a247f20f9f3ed7025c7f1b1db (patch)
treeef6795dd3965702c452d1cda9f752769e682bc1d /sys-devel/llvm-common/llvm-common-5.0.0.ebuild
parentsys-kernel/genkernel: bump. (diff)
downloadgentoo-5dfebe5f813c2a4a247f20f9f3ed7025c7f1b1db.tar.gz
gentoo-5dfebe5f813c2a4a247f20f9f3ed7025c7f1b1db.tar.bz2
gentoo-5dfebe5f813c2a4a247f20f9f3ed7025c7f1b1db.zip
sys-devel/llvm-common: Bump to 5.0.0
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-5.0.0.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-5.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-5.0.0.ebuild b/sys-devel/llvm-common/llvm-common-5.0.0.ebuild
new file mode 100644
index 000000000000..f53d09927137
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-5.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://releases.llvm.org/${PV/_//}/llvm-${PV/_/}.src.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+S=${WORKDIR}/llvm-${PV/_/}.src
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r utils/vim/*/
+ # some users may find it useful
+ newdoc utils/vim/README README.vim
+ dodoc utils/vim/vimrc
+}