summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-09 10:48:16 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-09 16:59:56 +0100
commitdcd5950b4c3a366bb3aaafd208626ceba54d83a0 (patch)
tree50bc4568089fad264f46c93d5a874ac622a33463 /sys-devel/llvm-common/llvm-common-6.0.0_rc2.ebuild
parentwww-client/chromium: remove old (diff)
downloadgentoo-dcd5950b4c3a366bb3aaafd208626ceba54d83a0.tar.gz
gentoo-dcd5950b4c3a366bb3aaafd208626ceba54d83a0.tar.bz2
gentoo-dcd5950b4c3a366bb3aaafd208626ceba54d83a0.zip
sys-devel/llvm-common: Bump to 6.0.0rc2
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-6.0.0_rc2.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-6.0.0_rc2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-6.0.0_rc2.ebuild b/sys-devel/llvm-common/llvm-common-6.0.0_rc2.ebuild
new file mode 100644
index 000000000000..8657a663c9e5
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-6.0.0_rc2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P=llvm-${PV/_/}.src
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="http://prereleases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ einfo "Unpacking parts of ${MY_P}.tar.xz ..."
+ tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/vim" || die
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r utils/vim/*/
+ # some users may find it useful
+ newdoc utils/vim/README README.vim
+ dodoc utils/vim/vimrc
+}