summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-20 10:52:22 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-20 14:49:49 +0200
commitc103664727221cafbaa32298f62fc9cc0b5e69a2 (patch)
tree79f36a34d6b62b3050267784ea9f74a7c1e0f6b9 /sys-devel/llvm-common/llvm-common-8.0.1.ebuild
parentnet-dialup/linux-atm: tweak for linux-headers-5.2 (diff)
downloadgentoo-c103664727221cafbaa32298f62fc9cc0b5e69a2.tar.gz
gentoo-c103664727221cafbaa32298f62fc9cc0b5e69a2.tar.bz2
gentoo-c103664727221cafbaa32298f62fc9cc0b5e69a2.zip
sys-devel/llvm-common: Bump to 8.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-8.0.1.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-8.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-8.0.1.ebuild b/sys-devel/llvm-common/llvm-common-8.0.1.ebuild
new file mode 100644
index 000000000000..a9bd1e16b47c
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-8.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P=llvm-${PV/_/}.src
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://github.com/llvm/llvm-project/releases/download/llvmorg-${PV}/${MY_P}.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ einfo "Unpacking parts of ${MY_P}.tar.xz ..."
+ tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/vim" || die
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r utils/vim/*/
+ # some users may find it useful
+ newdoc utils/vim/README README.vim
+ dodoc utils/vim/vimrc
+}