summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-15 20:36:14 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-15 20:41:30 +0200
commit140a8082e10b217c5993130edd362581e3b2e784 (patch)
tree1c67365166884a0b3cc4bc0d92622e8ca0ad5871 /sys-devel/llvm-common
parentllvm.org.eclass: master is now LLVM 12 (diff)
downloadgentoo-140a8082e10b217c5993130edd362581e3b2e784.tar.gz
gentoo-140a8082e10b217c5993130edd362581e3b2e784.tar.bz2
gentoo-140a8082e10b217c5993130edd362581e3b2e784.zip
sys-devel/llvm-common: Add 12.0.0.9999 for master branch
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm-common')
-rw-r--r--sys-devel/llvm-common/llvm-common-12.0.0.9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-12.0.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-12.0.0.9999.ebuild
new file mode 100644
index 000000000000..df9cf92b47a1
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-12.0.0.9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}