summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-20 12:24:12 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-20 18:32:22 +0200
commit7e56725dd39f8046f7abd39b1c9dcfd8c26faed8 (patch)
treec46f14342c48bcc1e3ac8817a67a230dd92db9a7 /sys-devel/llvm-common
parentnet-analyzer/zabbix: x86 stable (bug #728532) (diff)
downloadgentoo-7e56725dd39f8046f7abd39b1c9dcfd8c26faed8.tar.gz
gentoo-7e56725dd39f8046f7abd39b1c9dcfd8c26faed8.tar.bz2
gentoo-7e56725dd39f8046f7abd39b1c9dcfd8c26faed8.zip
sys-devel/llvm-common: Apply patches in WORKDIR in 10.0.1+
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm-common')
-rw-r--r--sys-devel/llvm-common/llvm-common-10.0.1.9999.ebuild7
-rw-r--r--sys-devel/llvm-common/llvm-common-10.0.1_rc1.ebuild5
-rw-r--r--sys-devel/llvm-common/llvm-common-11.0.0.9999.ebuild5
3 files changed, 16 insertions, 1 deletions
diff --git a/sys-devel/llvm-common/llvm-common-10.0.1.9999.ebuild b/sys-devel/llvm-common/llvm-common-10.0.1.9999.ebuild
index ba2ffc76a706..18d163abd5c8 100644
--- a/sys-devel/llvm-common/llvm-common-10.0.1.9999.ebuild
+++ b/sys-devel/llvm-common/llvm-common-10.0.1.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,6 +17,11 @@ IUSE=""
RDEPEND="!sys-devel/llvm:0"
+src_prepare() {
+ cd "${WORKDIR}" || Die
+ default
+}
+
src_install() {
insinto /usr/share/vim/vimfiles
doins -r */
diff --git a/sys-devel/llvm-common/llvm-common-10.0.1_rc1.ebuild b/sys-devel/llvm-common/llvm-common-10.0.1_rc1.ebuild
index df9cf92b47a1..18d163abd5c8 100644
--- a/sys-devel/llvm-common/llvm-common-10.0.1_rc1.ebuild
+++ b/sys-devel/llvm-common/llvm-common-10.0.1_rc1.ebuild
@@ -17,6 +17,11 @@ IUSE=""
RDEPEND="!sys-devel/llvm:0"
+src_prepare() {
+ cd "${WORKDIR}" || Die
+ default
+}
+
src_install() {
insinto /usr/share/vim/vimfiles
doins -r */
diff --git a/sys-devel/llvm-common/llvm-common-11.0.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-11.0.0.9999.ebuild
index df9cf92b47a1..18d163abd5c8 100644
--- a/sys-devel/llvm-common/llvm-common-11.0.0.9999.ebuild
+++ b/sys-devel/llvm-common/llvm-common-11.0.0.9999.ebuild
@@ -17,6 +17,11 @@ IUSE=""
RDEPEND="!sys-devel/llvm:0"
+src_prepare() {
+ cd "${WORKDIR}" || Die
+ default
+}
+
src_install() {
insinto /usr/share/vim/vimfiles
doins -r */