summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilfried Holzke <gentoo@holzke.net>2019-12-28 13:18:10 +0100
committerCraig Andrews <candrews@gentoo.org>2019-12-29 17:21:54 -0500
commit3ee99c860e04f770f755bd1ec34404e9bd8797d5 (patch)
treede9fc18eb1d869b003e958a23ce3bc2a01e92799 /sys-devel/llvm-roc/files
parentdev-libs/rocr-runtime: 3.0.0 version bump (diff)
downloadgentoo-3ee99c860e04f770f755bd1ec34404e9bd8797d5.tar.gz
gentoo-3ee99c860e04f770f755bd1ec34404e9bd8797d5.tar.bz2
gentoo-3ee99c860e04f770f755bd1ec34404e9bd8797d5.zip
sys-devel/llvm-roc: New ebuild for llvm-roc 3.0.0
Signed-off-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-2.3.79, Repoman-2.3.16 Closes: https://github.com/gentoo/gentoo/pull/14149 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'sys-devel/llvm-roc/files')
-rw-r--r--sys-devel/llvm-roc/files/llvm-roc-3.0.0-add_libraries.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/sys-devel/llvm-roc/files/llvm-roc-3.0.0-add_libraries.patch b/sys-devel/llvm-roc/files/llvm-roc-3.0.0-add_libraries.patch
new file mode 100644
index 000000000000..120ab819f5b4
--- /dev/null
+++ b/sys-devel/llvm-roc/files/llvm-roc-3.0.0-add_libraries.patch
@@ -0,0 +1,20 @@
+diff -Naur a/clang/lib/Basic/CMakeLists.txt b/clang/lib/Basic/CMakeLists.txt
+--- a/clang/lib/Basic/CMakeLists.txt 2019-12-28 07:42:49.119055933 +0100
++++ b/clang/lib/Basic/CMakeLists.txt 2019-12-28 07:42:13.265056070 +0100
+@@ -2,6 +2,7 @@
+ Core
+ MC
+ Support
++ Option
+ )
+
+ find_first_existing_vc_file("${LLVM_MAIN_SRC_DIR}" llvm_vc)
+diff -Naur a/clang/lib/Driver/CMakeLists.txt b/clang/lib/Driver/CMakeLists.txt
+--- a/clang/lib/Driver/CMakeLists.txt 2019-12-28 07:41:39.521056199 +0100
++++ b/clang/lib/Driver/CMakeLists.txt 2019-12-28 07:40:23.998056487 +0100
+@@ -79,4 +79,5 @@
+ LINK_LIBS
+ clangBasic
+ ${system_libs}
++ pthread
+ )