summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-21 10:32:59 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-21 11:15:35 +0200
commit41d1c512863be0d732d6f5fa25fe857212ff991a (patch)
treedba6aeeaf54e93268e8922db66143837c6c37537 /sys-devel/llvm/llvm-10.0.0.9999.ebuild
parentsys-devel/llvm-common: Reorder ebuild vars in 9+ (diff)
downloadgentoo-41d1c512863be0d732d6f5fa25fe857212ff991a.tar.gz
gentoo-41d1c512863be0d732d6f5fa25fe857212ff991a.tar.bz2
gentoo-41d1c512863be0d732d6f5fa25fe857212ff991a.zip
sys-devel/llvm: Reorder ebuild vars in 9+
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm/llvm-10.0.0.9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-10.0.0.9999.ebuild3
1 files changed, 1 insertions, 2 deletions
diff --git a/sys-devel/llvm/llvm-10.0.0.9999.ebuild b/sys-devel/llvm/llvm-10.0.0.9999.ebuild
index 131e44a7f887..e632d6c930c6 100644
--- a/sys-devel/llvm/llvm-10.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-10.0.0.9999.ebuild
@@ -36,6 +36,7 @@ SLOT="$(ver_cut 1)"
KEYWORDS=""
IUSE="debug doc exegesis gold libedit +libffi ncurses test xar xml z3
kernel_Darwin ${ALL_LLVM_TARGETS[*]}"
+REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -79,8 +80,6 @@ RDEPEND="${RDEPEND}
PDEPEND="sys-devel/llvm-common
gold? ( >=sys-devel/llvmgold-${SLOT} )"
-REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
-
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo