summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-22 13:12:59 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-22 13:21:37 +0200
commita473a7a0611264f648e8a6a7518c4616c6c153fc (patch)
treea0a25dddd167e4afc5bf591f9ba696a74fac17db /sys-devel/llvm/llvm-10.0.1.ebuild
parentllvm.org.eclass: Support Gentoo patchsets (diff)
downloadgentoo-a473a7a0611264f648e8a6a7518c4616c6c153fc.tar.gz
gentoo-a473a7a0611264f648e8a6a7518c4616c6c153fc.tar.bz2
gentoo-a473a7a0611264f648e8a6a7518c4616c6c153fc.zip
sys-devel/llvm: Switch to patchsets
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm/llvm-10.0.1.ebuild')
-rw-r--r--sys-devel/llvm/llvm-10.0.1.ebuild11
1 files changed, 1 insertions, 10 deletions
diff --git a/sys-devel/llvm/llvm-10.0.1.ebuild b/sys-devel/llvm/llvm-10.0.1.ebuild
index cd9bb97a261d..390045cc96e7 100644
--- a/sys-devel/llvm/llvm-10.0.1.ebuild
+++ b/sys-devel/llvm/llvm-10.0.1.ebuild
@@ -11,6 +11,7 @@ DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
LLVM_COMPONENTS=( llvm )
LLVM_MANPAGES=pregenerated
+LLVM_PATCHSET=10.0.1-1
llvm.org_set_globals
# Those are in lib/Targets, without explicit CMakeLists.txt mention
@@ -67,12 +68,6 @@ RDEPEND="${RDEPEND}
PDEPEND="sys-devel/llvm-common
gold? ( >=sys-devel/llvmgold-${SLOT} )"
-PATCHES=(
- # Fix linking to dylib and .a libs simultaneously
- "${FILESDIR}"/10.0.1/0001-llvm-Avoid-linking-llvm-cfi-verify-to-duplicate-libs.patch
- "${FILESDIR}"/10.0.1/0002-llvm-Disable-linking-llvm-exegesis-to-dylib.patch
-)
-
python_check_deps() {
use doc || return 0
@@ -141,10 +136,6 @@ check_distribution_components() {
}
src_prepare() {
- # Fix llvm-config for shared linking and sane flags
- # https://bugs.gentoo.org/show_bug.cgi?id=565358
- eapply "${FILESDIR}"/9999/0007-llvm-config-Clean-up-exported-values-update-for-shar.patch
-
# disable use of SDK on OSX, bug #568758
sed -i -e 's/xcrun/false/' utils/lit/lit/util.py || die