summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-08-24 17:29:03 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2015-08-24 17:30:29 +0200
commit5a12ed0f73c8773aaa230e8d66ffce7ea329f866 (patch)
tree1d80a2afd800f4407d1645a31a2a362f9bda5600 /sys-devel/llvm/llvm-9999.ebuild
parentdev-java/{burlap,caucho-services}: removal. Fixes bug 554962. (diff)
downloadgentoo-5a12ed0f73c8773aaa230e8d66ffce7ea329f866.tar.gz
gentoo-5a12ed0f73c8773aaa230e8d66ffce7ea329f866.tar.bz2
gentoo-5a12ed0f73c8773aaa230e8d66ffce7ea329f866.zip
sys-devel/llvm: fix live ebuild
Fixes bugs #553416, #557100 and #557154
Diffstat (limited to 'sys-devel/llvm/llvm-9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index aa013b67f400..a11342a1077e 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -168,6 +168,9 @@ src_prepare() {
# https://llvm.org/bugs/show_bug.cgi?id=18341
epatch "${FILESDIR}"/cmake/0004-cmake-Do-not-install-libgtest.patch
+ # Allow custom cmake build types (like 'Gentoo')
+ epatch "${FILESDIR}"/cmake/${PN}-3.8-allow_custom_cmake_build_types.patch
+
if use clang; then
# Automatically select active system GCC's libraries, bugs #406163 and #417913
epatch "${FILESDIR}"/clang-3.5-gentoo-runtime-gcc-detection-v3.patch
@@ -179,13 +182,16 @@ src_prepare() {
# Install clang runtime into /usr/lib/clang
# https://llvm.org/bugs/show_bug.cgi?id=23792
- epatch "${FILESDIR}"/cmake/clang-0001-Install-clang-runtime-into-usr-lib-without-suffix.patch
+ epatch "${FILESDIR}"/cmake/clang-0001-Install-clang-runtime-into-usr-lib-without-suffix-3.8.patch
epatch "${FILESDIR}"/cmake/compiler-rt-0001-cmake-Install-compiler-rt-into-usr-lib-without-suffi.patch
# Make it possible to override CLANG_LIBDIR_SUFFIX
# (that is used only to find LLVMgold.so)
# https://llvm.org/bugs/show_bug.cgi?id=23793
epatch "${FILESDIR}"/cmake/clang-0002-cmake-Make-CLANG_LIBDIR_SUFFIX-overridable.patch
+
+ # Workaround bug #553416 until upstream fixes it
+ epatch "${FILESDIR}"/clang-3.7-strip_doc_refs.patch
fi
if use lldb; then