summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-01-27 23:35:24 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2016-01-27 23:35:36 +0100
commite63ee31ad20bfd2d7e2159c63b62913bfd001353 (patch)
treee170bf2d969d24f8437c75021805c7a78f6ae0d2 /sys-devel/llvm/llvm-9999.ebuild
parentsys-fs/spl-0.6.5.4{,-r1}: Version Bump (diff)
downloadgentoo-e63ee31ad20bfd2d7e2159c63b62913bfd001353.tar.gz
gentoo-e63ee31ad20bfd2d7e2159c63b62913bfd001353.tar.bz2
gentoo-e63ee31ad20bfd2d7e2159c63b62913bfd001353.zip
sys-devel/llvm: add (masked) 3.8 release candidate for testing
Package-Manager: portage-2.2.27
Diffstat (limited to 'sys-devel/llvm/llvm-9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index d9adc68fc25f..c0f1cfc7f65c 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -142,6 +142,8 @@ src_prepare() {
sed -e "/RUN/s/-warn-error A//" -i test/Bindings/OCaml/*ml || die
# Fix libdir for ocaml bindings install, bug #559134
epatch "${FILESDIR}"/cmake/${PN}-3.7.0-ocaml-multilib.patch
+ # Do not build/install ocaml docs with USE=-doc, bug #562008
+ epatch "${FILESDIR}"/cmake/${PN}-3.7.0-ocaml-build_doc.patch
# Make it possible to override Sphinx HTML install dirs
# https://llvm.org/bugs/show_bug.cgi?id=23780
@@ -221,7 +223,7 @@ multilib_src_configure() {
"${mycmakeargs[@]}"
-DLLVM_LIBDIR_SUFFIX=${libdir#lib}
- -DBUILD_SHARED_LIBS=ON
+ -DLLVM_LINK_LLVM_DYLIB=ON
-DLLVM_ENABLE_TIMESTAMPS=OFF
-DLLVM_TARGETS_TO_BUILD="${targets}"
-DLLVM_BUILD_TESTS=$(usex test)