summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-25 20:09:04 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-25 20:09:23 +0100
commit1e414463fb8a3d00d5f15f86680f41b0a67e28b4 (patch)
tree9cc92dd53eef4b2021d1f56834c1ddc012a43a58 /sys-devel/llvm
parentmedia-radio/ibp: Drop old (diff)
downloadgentoo-1e414463fb8a3d00d5f15f86680f41b0a67e28b4.tar.gz
gentoo-1e414463fb8a3d00d5f15f86680f41b0a67e28b4.tar.bz2
gentoo-1e414463fb8a3d00d5f15f86680f41b0a67e28b4.zip
sys-devel/llvm: Install libFuzzer only for Darwin||Linux
Install libFuzzer only on platforms where it is actually built, that is Darwin and Linux. This fixes install failure on FreeBSD.
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-5.0.1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sys-devel/llvm/llvm-5.0.1.ebuild b/sys-devel/llvm/llvm-5.0.1.ebuild
index c4ebf78be0aa..809795ffd0a3 100644
--- a/sys-devel/llvm/llvm-5.0.1.ebuild
+++ b/sys-devel/llvm/llvm-5.0.1.ebuild
@@ -35,7 +35,7 @@ LICENSE="UoI-NCSA rc BSD public-domain
SLOT="$(ver_cut 1)"
KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="debug doc gold libedit +libffi ncurses test
- kernel_Darwin ${ALL_LLVM_TARGETS[*]}"
+ kernel_Darwin kernel_linux ${ALL_LLVM_TARGETS[*]}"
RDEPEND="
sys-libs/zlib:0=
@@ -211,10 +211,12 @@ multilib_src_install() {
rm -rf "${ED%/}"/usr/include || die
mv "${ED%/}"/usr/lib/llvm/${SLOT}/include "${ED%/}"/usr/include || die
- # install fuzzer libraries for clang (cmake rules were added in 6)
- # https://bugs.gentoo.org/636840
- into "/usr/lib/llvm/${SLOT}"
- dolib.a "$(get_libdir)"/libLLVMFuzzer*.a
+ if use kernel_linux || use kernel_Darwin; then
+ # install fuzzer libraries for clang (cmake rules were added in 6)
+ # https://bugs.gentoo.org/636840
+ into "/usr/lib/llvm/${SLOT}"
+ dolib.a "$(get_libdir)"/libLLVMFuzzer*.a
+ fi
LLVM_LDPATHS+=( "${EPREFIX}/usr/lib/llvm/${SLOT}/$(get_libdir)" )
}