summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-08-29 23:40:51 +0200
committerMichał Górny <mgorny@gentoo.org>2016-08-29 23:43:18 +0200
commit6b3fc923145a19ae5bf212ed7fac4969c6fef1c5 (patch)
tree4d9131d5c0054492a7d5d73af564d07592a1b766 /sys-devel/llvm
parentmedia-sound/tuxguitar: Only call append-flags once to avoid duplicates (diff)
downloadgentoo-6b3fc923145a19ae5bf212ed7fac4969c6fef1c5.tar.gz
gentoo-6b3fc923145a19ae5bf212ed7fac4969c6fef1c5.tar.bz2
gentoo-6b3fc923145a19ae5bf212ed7fac4969c6fef1c5.zip
sys-devel/llvm: Fix cmake unused arg warnings with USE=-doc
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index e4be8854227a..6fbe8c886b8e 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -188,16 +188,15 @@ multilib_src_configure() {
-DLLVM_BUILD_DOCS=$(usex doc)
-DLLVM_ENABLE_SPHINX=$(usex doc)
-DLLVM_ENABLE_DOXYGEN=OFF
+ -DLLVM_INSTALL_UTILS=ON
+ )
+ use doc && mycmakeargs+=(
-DLLVM_INSTALL_HTML="${EPREFIX}/usr/share/doc/${PF}/html"
-DSPHINX_WARNINGS_AS_ERRORS=OFF
- -DLLVM_INSTALL_UTILS=ON
)
-
- if use gold; then
- mycmakeargs+=(
- -DLLVM_BINUTILS_INCDIR="${EPREFIX}"/usr/include
- )
- fi
+ use gold && mycmakeargs+=(
+ -DLLVM_BINUTILS_INCDIR="${EPREFIX}"/usr/include
+ )
fi
if tc-is-cross-compiler; then