summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-09-10 10:22:57 +0200
committerFabian Groffen <grobian@gentoo.org>2016-09-10 10:22:57 +0200
commit6c324f1ccdf021ce6b923a5c0589572c4d3cfd28 (patch)
treeff0dbe4a2aac5151590708104051bab7a83b8f18 /sys-devel/llvm
parentnet-analyzer/wireshark: Stable for PPC64 (bug #593258). (diff)
downloadgentoo-6c324f1ccdf021ce6b923a5c0589572c4d3cfd28.tar.gz
gentoo-6c324f1ccdf021ce6b923a5c0589572c4d3cfd28.tar.bz2
gentoo-6c324f1ccdf021ce6b923a5c0589572c4d3cfd28.zip
sys-devel/llvm: move libcxx into PDEPEND for Darwin
llvm needs libcxx-headers at most, but not the library, however, llvm does segfault if the matching libcxx isn't available at runtime, so make sure we install a matching version after installing llvm on Darwin. Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-3.5.2.ebuild4
-rw-r--r--sys-devel/llvm/llvm-3.7.1-r3.ebuild4
-rw-r--r--sys-devel/llvm/llvm-3.8.1-r2.ebuild4
-rw-r--r--sys-devel/llvm/llvm-3.8.1.ebuild4
-rw-r--r--sys-devel/llvm/llvm-3.9.0.ebuild3
5 files changed, 10 insertions, 9 deletions
diff --git a/sys-devel/llvm/llvm-3.5.2.ebuild b/sys-devel/llvm/llvm-3.5.2.ebuild
index a4f1139d4952..62acb5af863e 100644
--- a/sys-devel/llvm/llvm-3.5.2.ebuild
+++ b/sys-devel/llvm/llvm-3.5.2.ebuild
@@ -50,7 +50,6 @@ DEPEND="${COMMON_DEPEND}
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-5.1 )
- kernel_Darwin? ( <sys-libs/libcxx-${PV%_rc*}.9999 )
clang? ( xml? ( virtual/pkgconfig ) )
doc? ( dev-python/sphinx )
libffi? ( virtual/pkgconfig )
@@ -61,7 +60,8 @@ RDEPEND="${COMMON_DEPEND}
!>=sys-devel/clang-9999 )
abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r2
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
-PDEPEND="clang? ( =sys-devel/clang-${PV}-r100 )"
+PDEPEND="clang? ( =sys-devel/clang-${PV}-r100 )
+ kernel_Darwin? ( =sys-libs/libcxx-${SLOT#*/}* )"
# pypy gives me around 1700 unresolved tests due to open file limit
# being exceeded. probably GC does not close them fast enough.
diff --git a/sys-devel/llvm/llvm-3.7.1-r3.ebuild b/sys-devel/llvm/llvm-3.7.1-r3.ebuild
index a933eb617f0e..b8805b0aacf9 100644
--- a/sys-devel/llvm/llvm-3.7.1-r3.ebuild
+++ b/sys-devel/llvm/llvm-3.7.1-r3.ebuild
@@ -55,7 +55,6 @@ DEPEND="${COMMON_DEPEND}
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-5.1 )
- kernel_Darwin? ( <sys-libs/libcxx-${PV%_rc*}.9999 )
clang? ( xml? ( virtual/pkgconfig ) )
doc? ( dev-python/sphinx )
gold? ( sys-libs/binutils-libs )
@@ -68,7 +67,8 @@ RDEPEND="${COMMON_DEPEND}
clang? ( !<=sys-devel/clang-${PV}-r99 )
abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r2
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
-PDEPEND="clang? ( =sys-devel/clang-${PV}-r100 )"
+PDEPEND="clang? ( =sys-devel/clang-${PV}-r100 )
+ kernel_Darwin? ( =sys-libs/libcxx-${PV}* )"
# pypy gives me around 1700 unresolved tests due to open file limit
# being exceeded. probably GC does not close them fast enough.
diff --git a/sys-devel/llvm/llvm-3.8.1-r2.ebuild b/sys-devel/llvm/llvm-3.8.1-r2.ebuild
index 195d8ec78c89..14a2e82d508c 100644
--- a/sys-devel/llvm/llvm-3.8.1-r2.ebuild
+++ b/sys-devel/llvm/llvm-3.8.1-r2.ebuild
@@ -55,7 +55,6 @@ DEPEND="${COMMON_DEPEND}
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-5.1 )
- kernel_Darwin? ( <sys-libs/libcxx-${PV%_rc*}.9999 )
clang? ( xml? ( virtual/pkgconfig ) )
doc? ( dev-python/sphinx )
gold? ( sys-libs/binutils-libs )
@@ -70,7 +69,8 @@ RDEPEND="${COMMON_DEPEND}
abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r2
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
PDEPEND="clang? ( =sys-devel/clang-${PV}-r100 )
- default-libcxx? ( sys-libs/libcxx )"
+ default-libcxx? ( sys-libs/libcxx )
+ kernel_Darwin? ( =sys-libs/libcxx-${PV%.*}* )"
# pypy gives me around 1700 unresolved tests due to open file limit
# being exceeded. probably GC does not close them fast enough.
diff --git a/sys-devel/llvm/llvm-3.8.1.ebuild b/sys-devel/llvm/llvm-3.8.1.ebuild
index 4846dcdb9b29..81d3f0fbe2fb 100644
--- a/sys-devel/llvm/llvm-3.8.1.ebuild
+++ b/sys-devel/llvm/llvm-3.8.1.ebuild
@@ -56,7 +56,6 @@ DEPEND="${COMMON_DEPEND}
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-5.1 )
- kernel_Darwin? ( <sys-libs/libcxx-${PV%_rc*}.9999 )
clang? ( xml? ( virtual/pkgconfig ) )
doc? ( dev-python/sphinx )
gold? ( sys-libs/binutils-libs )
@@ -69,7 +68,8 @@ RDEPEND="${COMMON_DEPEND}
clang? ( !<=sys-devel/clang-${PV}-r99 )
abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r2
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
-PDEPEND="clang? ( =sys-devel/clang-${PV}-r100 )"
+PDEPEND="clang? ( =sys-devel/clang-${PV}-r100 )
+ kernel_Darwin? ( =sys-libs/libcxx-${PV%.*}* )"
# pypy gives me around 1700 unresolved tests due to open file limit
# being exceeded. probably GC does not close them fast enough.
diff --git a/sys-devel/llvm/llvm-3.9.0.ebuild b/sys-devel/llvm/llvm-3.9.0.ebuild
index ec4ce048623c..ae3d20555fd5 100644
--- a/sys-devel/llvm/llvm-3.9.0.ebuild
+++ b/sys-devel/llvm/llvm-3.9.0.ebuild
@@ -72,7 +72,8 @@ RDEPEND="${COMMON_DEPEND}
abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r2
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
PDEPEND="clang? ( =sys-devel/clang-${PV}-r100 )
- default-libcxx? ( sys-libs/libcxx )"
+ default-libcxx? ( sys-libs/libcxx )
+ kernel_Darwin? ( =sys-libs/libcxx-${PV%.*}* )"
# pypy gives me around 1700 unresolved tests due to open file limit
# being exceeded. probably GC does not close them fast enough.