summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-08 22:58:35 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-08 23:18:53 +0100
commit6f92382169da4cd3942b866af9191ffa309afc96 (patch)
tree4043c074a465a29bbdca7dfe9414982d16ebe3be /sys-devel/llvm
parentdev-python/lit: Control lit job count (diff)
downloadgentoo-6f92382169da4cd3942b866af9191ffa309afc96.tar.gz
gentoo-6f92382169da4cd3942b866af9191ffa309afc96.tar.bz2
gentoo-6f92382169da4cd3942b866af9191ffa309afc96.zip
sys-devel/llvm: Control lit job count
Closes: https://bugs.gentoo.org/649554
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-6.0.9999.ebuild4
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-devel/llvm/llvm-6.0.9999.ebuild b/sys-devel/llvm/llvm-6.0.9999.ebuild
index a0f997bfbd73..d460300fe422 100644
--- a/sys-devel/llvm/llvm-6.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-6.0.9999.ebuild
@@ -9,7 +9,7 @@ CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
inherit cmake-utils eapi7-ver flag-o-matic git-r3 multilib-minimal \
- pax-utils python-any-r1 toolchain-funcs
+ multiprocessing pax-utils python-any-r1 toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
@@ -136,7 +136,7 @@ multilib_src_configure() {
# fi
use test && mycmakeargs+=(
- -DLLVM_LIT_ARGS="-vv"
+ -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
)
if multilib_is_native_abi; then
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 85c7b23b9874..ca30a2f3e4fb 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -9,7 +9,7 @@ CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
inherit cmake-utils eapi7-ver flag-o-matic git-r3 multilib-minimal \
- pax-utils python-any-r1 toolchain-funcs
+ multiprocessing pax-utils python-any-r1 toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
@@ -141,7 +141,7 @@ multilib_src_configure() {
# fi
use test && mycmakeargs+=(
- -DLLVM_LIT_ARGS="-vv"
+ -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
)
if multilib_is_native_abi; then