summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-27 05:23:14 +0100
committerSam James <sam@gentoo.org>2022-07-27 05:23:14 +0100
commit945e7ceda30f34dadd8774c64d838dc8c4da423d (patch)
tree5dafe424bf7b86992cc23bf1cb55d226932539cd /sys-devel/llvmgold/llvmgold-13-r2.ebuild
parentprofiles/arch/sparc: cleanup sparc LLVM masks (diff)
downloadgentoo-945e7ceda30f34dadd8774c64d838dc8c4da423d.tar.gz
gentoo-945e7ceda30f34dadd8774c64d838dc8c4da423d.tar.bz2
gentoo-945e7ceda30f34dadd8774c64d838dc8c4da423d.zip
sys-devel/llvmgold: drop llvm[gold] references
This ended up covering up some broken/stale masks referring to the old USE flag in profiles/. Let's just get rid of the compatibility hack given all LLVMs in tree (including 13.x) have USE=binutils-plugin instead. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/llvmgold/llvmgold-13-r2.ebuild')
-rw-r--r--sys-devel/llvmgold/llvmgold-13-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/llvmgold/llvmgold-13-r2.ebuild b/sys-devel/llvmgold/llvmgold-13-r2.ebuild
new file mode 100644
index 000000000000..c5b814adfa63
--- /dev/null
+++ b/sys-devel/llvmgold/llvmgold-13-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="LLVMgold plugin symlink for autoloading"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux"
+
+RDEPEND="
+ sys-devel/llvm:${PV}[binutils-plugin(-)]
+ !sys-devel/llvm:0"
+
+S=${WORKDIR}
+
+src_install() {
+ dodir "/usr/${CHOST}/binutils-bin/lib/bfd-plugins"
+ dosym "../../../../lib/llvm/${PV}/$(get_libdir)/LLVMgold.so" \
+ "/usr/${CHOST}/binutils-bin/lib/bfd-plugins/LLVMgold.so"
+}