summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-11-11 11:36:43 +0000
committerMatthew Smith <matthew@gentoo.org>2022-11-11 11:36:43 +0000
commit675a146d9e0476478e62e8e647cc3d3bcdde8991 (patch)
tree89afc1369a51f06c9f2310e8808169f000a26b4d /sys-devel/mold
parentmedia-video/webcamoid: add a missing qtdbus dependency on 9.0.0 (diff)
downloadgentoo-675a146d9e0476478e62e8e647cc3d3bcdde8991.tar.gz
gentoo-675a146d9e0476478e62e8e647cc3d3bcdde8991.tar.bz2
gentoo-675a146d9e0476478e62e8e647cc3d3bcdde8991.zip
sys-devel/mold: update live ebuild
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'sys-devel/mold')
-rw-r--r--sys-devel/mold/mold-9999.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sys-devel/mold/mold-9999.ebuild b/sys-devel/mold/mold-9999.ebuild
index 34d7e10e3bf1..45c7fd085eb8 100644
--- a/sys-devel/mold/mold-9999.ebuild
+++ b/sys-devel/mold/mold-9999.ebuild
@@ -12,20 +12,18 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/rui314/mold/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~riscv"
+ KEYWORDS="~amd64 ~riscv ~x86"
fi
# mold (AGPL-3)
# - xxhash (BSD-2)
-# - tbb (Apache-2.0)
-LICENSE="AGPL-3 Apache-2.0 BSD-2"
+LICENSE="AGPL-3 BSD-2"
SLOT="0"
-IUSE="system-tbb"
RDEPEND="
app-arch/zstd:=
+ >=dev-cpp/tbb-2021.7.0:=
sys-libs/zlib
- system-tbb? ( >=dev-cpp/tbb-2021.4.0:= )
!kernel_Darwin? (
>=dev-libs/mimalloc-2:=
dev-libs/openssl:=
@@ -75,7 +73,7 @@ src_configure() {
-DMOLD_ENABLE_QEMU_TESTS=OFF
-DMOLD_LTO=OFF # Should be up to the user to decide this with CXXFLAGS.
-DMOLD_USE_SYSTEM_MIMALLOC=ON
- -DMOLD_USE_SYSTEM_TBB=$(usex system-tbb)
+ -DMOLD_USE_SYSTEM_TBB=ON
)
cmake_src_configure
}