summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-06-26 13:52:04 +0100
committerMatthew Smith <matthew@gentoo.org>2022-06-26 13:54:23 +0100
commit6eac8f2838eee9953bfc4ab0ece59cf396d6e026 (patch)
treea699dc7f9d4cb27d19d24c4d0c73d366714cfca8 /sys-devel/mold
parentsys-devel/mold: use pkg-config to find OpenSSL (diff)
downloadgentoo-6eac8f2838eee9953bfc4ab0ece59cf396d6e026.tar.gz
gentoo-6eac8f2838eee9953bfc4ab0ece59cf396d6e026.tar.bz2
gentoo-6eac8f2838eee9953bfc4ab0ece59cf396d6e026.zip
sys-devel/mold: fix tests
Fix LD_PRELOAD path in mold-wrapper tests, and delete more tests that require QEMU. Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'sys-devel/mold')
-rw-r--r--sys-devel/mold/mold-9999.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-devel/mold/mold-9999.ebuild b/sys-devel/mold/mold-9999.ebuild
index d5c163c1ba90..1fe9a5a08e35 100644
--- a/sys-devel/mold/mold-9999.ebuild
+++ b/sys-devel/mold/mold-9999.ebuild
@@ -53,10 +53,11 @@ src_prepare() {
# Heavy tests, need qemu
rm test/elf/gdb-index-{compress-output,dwarf{2,3,4,5}}.sh || die
+ rm test/elf/lto-{archive,dso,gcc,llvm,version-script}.sh || die
# Sandbox sadness
rm test/elf/run.sh || die
- sed -i 's|$mold-wrapper.so|"& ${LD_PRELOAD}"|' \
+ sed -i 's|`pwd`/mold-wrapper.so|"& ${LD_PRELOAD}"|' \
test/elf/mold-wrapper{,2}.sh || die
# static-pie tests require glibc built with static-pie support