summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-21 02:13:26 +0000
committerSam James <sam@gentoo.org>2022-02-21 02:13:26 +0000
commit9df6c67da670972816b47909d431bd263e57b708 (patch)
tree024b1da9cf84be366e2f7c80c4d3cd9669172bb0 /sys-devel/mold
parentsci-libs/openblas: add 0.3.20 (diff)
downloadgentoo-9df6c67da670972816b47909d431bd263e57b708.tar.gz
gentoo-9df6c67da670972816b47909d431bd263e57b708.tar.bz2
gentoo-9df6c67da670972816b47909d431bd263e57b708.zip
sys-devel/mold: add 1.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/mold')
-rw-r--r--sys-devel/mold/Manifest1
-rw-r--r--sys-devel/mold/mold-1.1.ebuild70
-rw-r--r--sys-devel/mold/mold-9999.ebuild5
3 files changed, 73 insertions, 3 deletions
diff --git a/sys-devel/mold/Manifest b/sys-devel/mold/Manifest
index 0c5e13683969..585e6bd1feb1 100644
--- a/sys-devel/mold/Manifest
+++ b/sys-devel/mold/Manifest
@@ -1 +1,2 @@
DIST mold-1.0.3.tar.gz 4501162 BLAKE2B 68db6708ae05b3a4caf19bff8b381c9a7d045b7313e15ee9c0765042ef02898404527735a8f5379a2d213a7654f656cfe24eb20497d6d4f5e9ed666988050733 SHA512 50b4a80c8b7a4925e6e85a35e92529867648df61ca016ee662b3fce7cf9d4a8fd717311ec0542aa594f44b49d48de34d51d7e94cae0f21bda01fdd4418990f38
+DIST mold-1.1.tar.gz 4522886 BLAKE2B 6c63c171a6da090c3db391fa90e0095b2ab6f995e1d23be0dd93bb3057b3b9e5f5cf1deab5c80f6db3fa58bab69195a07a7e972373b9f1e633687cb8d4d45361 SHA512 b8b125c77563abe2741c2f32d73ab2b12dff275b92b633fcd015336c6ea735e38e95c3d2afb50e5baace2023d4f9de3eb50d53053eabc2cd2f045110eef4cc1e
diff --git a/sys-devel/mold/mold-1.1.ebuild b/sys-devel/mold/mold-1.1.ebuild
new file mode 100644
index 000000000000..caa630e22c18
--- /dev/null
+++ b/sys-devel/mold/mold-1.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A Modern Linker"
+HOMEPAGE="https://github.com/rui314/mold"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/rui314/mold.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/rui314/mold/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="AGPL-3"
+SLOT="0"
+
+# Try again after 1.0 (nearly there, but path-related issues)
+# https://github.com/rui314/mold/issues/137
+RESTRICT="test"
+
+RDEPEND=">=dev-cpp/tbb-2021.4.0:=
+ sys-libs/zlib
+ !kernel_Darwin? (
+ >=dev-libs/mimalloc-2:=
+ dev-libs/openssl:=
+ )"
+# As of 1.1, xxhash is now a header-only dep, but it's now bundled :(
+# TODO: restore SYSTEM_XXHASH upstream?
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # Needs unpackaged dwarfdump
+ rm test/elf/{compress-debug-sections,compressed-debug-info}.sh || die
+}
+
+src_compile() {
+ tc-export CC CXX
+
+ emake \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ SYSTEM_TBB=1 \
+ SYSTEM_MIMALLOC=1 \
+ STRIP="true" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_test() {
+ emake \
+ SYSTEM_TBB=1 \
+ SYSTEM_MIMALLOC=1 \
+ check
+}
+
+src_install() {
+ emake \
+ SYSTEM_TBB=1 \
+ SYSTEM_MIMALLOC=1 \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ STRIP="true" \
+ install
+}
diff --git a/sys-devel/mold/mold-9999.ebuild b/sys-devel/mold/mold-9999.ebuild
index 7948bbc23805..caa630e22c18 100644
--- a/sys-devel/mold/mold-9999.ebuild
+++ b/sys-devel/mold/mold-9999.ebuild
@@ -23,12 +23,13 @@ SLOT="0"
RESTRICT="test"
RDEPEND=">=dev-cpp/tbb-2021.4.0:=
- dev-libs/xxhash:=
sys-libs/zlib
!kernel_Darwin? (
>=dev-libs/mimalloc-2:=
dev-libs/openssl:=
)"
+# As of 1.1, xxhash is now a header-only dep, but it's now bundled :(
+# TODO: restore SYSTEM_XXHASH upstream?
DEPEND="${RDEPEND}"
src_prepare() {
@@ -46,7 +47,6 @@ src_compile() {
CXXFLAGS="${CXXFLAGS}" \
SYSTEM_TBB=1 \
SYSTEM_MIMALLOC=1 \
- SYSTEM_XXHASH=1 \
STRIP="true" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)"
}
@@ -62,7 +62,6 @@ src_install() {
emake \
SYSTEM_TBB=1 \
SYSTEM_MIMALLOC=1 \
- SYSTEM_XXHASH=1 \
DESTDIR="${D}" \
PREFIX="${EPREFIX}/usr" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)" \