summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-15 02:11:35 +0000
committerSam James <sam@gentoo.org>2021-12-15 02:11:35 +0000
commitfb03cbc17bca78574761970e614cb2b1faec9fad (patch)
treedf3728ec0e21fa7b345da7b8247f0fb671a0730f /sys-devel/mold
parentsys-devel/mold: simplify 9999 (diff)
downloadgentoo-fb03cbc17bca78574761970e614cb2b1faec9fad.tar.gz
gentoo-fb03cbc17bca78574761970e614cb2b1faec9fad.tar.bz2
gentoo-fb03cbc17bca78574761970e614cb2b1faec9fad.zip
sys-devel/mold: update 9999 for tests
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/mold')
-rw-r--r--sys-devel/mold/mold-9999.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/sys-devel/mold/mold-9999.ebuild b/sys-devel/mold/mold-9999.ebuild
index 4ba32b129af9..3f25d6ac3628 100644
--- a/sys-devel/mold/mold-9999.ebuild
+++ b/sys-devel/mold/mold-9999.ebuild
@@ -18,7 +18,7 @@ fi
LICENSE="AGPL-3"
SLOT="0"
-# Try again after 0.9.6
+# Try again after 1.0 (nearly there, but path-related issues)
RESTRICT="test"
RDEPEND=">=dev-cpp/tbb-2021.4.0:=
@@ -30,6 +30,13 @@ RDEPEND=">=dev-cpp/tbb-2021.4.0:=
)"
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+
+ # Needs unpackaged dwarfdump
+ rm test/elf/{compress-debug-sections.sh,compressed-debug-info.sh} || die
+}
+
src_compile() {
tc-export CC CXX
@@ -41,12 +48,7 @@ src_compile() {
}
src_test() {
- emake \
- SYSTEM_TBB=1 \
- SYSTEM_MIMALLOC=1 \
- LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
- STRIP="true"
- check
+ emake -C test -f Makefile.linux test
}
src_install() {