summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-13 13:08:53 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-13 13:09:15 -0800
commit16d780eadc15ea8b6a88c97688a669e128587991 (patch)
tree39b5b26a281ae02717093b092e1243f1c014fad3 /sys-devel/rust-std
parentsys-devel/rust-std: add 1.58.0 (diff)
downloadgentoo-16d780eadc15ea8b6a88c97688a669e128587991.tar.gz
gentoo-16d780eadc15ea8b6a88c97688a669e128587991.tar.bz2
gentoo-16d780eadc15ea8b6a88c97688a669e128587991.zip
sys-devel/rust-std: drop 1.51.0, 1.52.1
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-devel/rust-std')
-rw-r--r--sys-devel/rust-std/Manifest2
-rw-r--r--sys-devel/rust-std/rust-std-1.51.0.ebuild156
-rw-r--r--sys-devel/rust-std/rust-std-1.52.1.ebuild154
3 files changed, 0 insertions, 312 deletions
diff --git a/sys-devel/rust-std/Manifest b/sys-devel/rust-std/Manifest
index d255219d8cb9..408325747f02 100644
--- a/sys-devel/rust-std/Manifest
+++ b/sys-devel/rust-std/Manifest
@@ -1,5 +1,3 @@
-DIST rustc-1.51.0-src.tar.xz 109596164 BLAKE2B c1ac89655adfe7db8005476d42c748cf1896f52888141229fd6dda43855dbb08c21c8e1f11398d2f1f9dd5f8d508d9158a3bda4f1b282d1b184ea4c701100837 SHA512 ded91468ddf3e6627f00e7ec3d44452aa24eb727a183c0de9d90264f593119a54300d56b09251a88260db480b48554181ae195c538996a32d68d48b6587ac0df
-DIST rustc-1.52.1-src.tar.xz 115109508 BLAKE2B c5d73f5884037d287d88ba9fdaf63a36678b692e1b510920045797ab29f1660f05cda901e19411ff83ec3084c4130034c269976b1056220f3e629cff116d07f0 SHA512 55f5053ce40d4eba4663052817aef6a6275139ca229c89cd1ec44711458b412720203301d8c7975aac5720a91fcaf21847f8184f641cbb0004f722520283c73c
DIST rustc-1.53.0-src.tar.xz 115686332 BLAKE2B fa068f89d42f927fdc79ee31aad1386eaf2aa596a060e059c5a1a73fe48c48d008fc952cd6c7912b743e41d77a94b205639eed0f728b2539b62f18a772cabfe3 SHA512 70485cf7a0f7fc36ee31644e546374079dc387a85b44e5e793707fd0a4d7ca05d311291e78b86db955485d8f21c47ff9e1908acc4da68ba04929287213a40c24
DIST rustc-1.54.0-src.tar.xz 116286856 BLAKE2B 5ac47822646a0b6205f09282168b4d4ddcace9f6bc8f242c890327ca4074626f129514f8bcae5c5556015745f718990cce490658076f5cd3526623439540416b SHA512 5162f85b43ca2c5af93fdbfb2597d75df8a838f7fcc025a5298499ce1043db50f1ea2fbba753e47ce5daad3d80d4b612acf6527ef902c34117763e687fdbbcfa
DIST rustc-1.55.0-src.tar.xz 117197580 BLAKE2B 8d9739ce7571146aee0e07c6287de9a8c4f1a914606cd47819eb1ef118b15772ecf22d0d43d7732f03c234a013fa54a4a7f0578a3f136af518f71bf64a03305d SHA512 7522f2fa95d5af92472404ecc97d7d9e745e88c933196a83fa373ce1efff6db3c295e0e2afdbfa1ff00644554efa0c3c7f6c11f9119ecf9010cb440b3f27c2da
diff --git a/sys-devel/rust-std/rust-std-1.51.0.ebuild b/sys-devel/rust-std/rust-std-1.51.0.ebuild
deleted file mode 100644
index 935388d41a01..000000000000
--- a/sys-devel/rust-std/rust-std-1.51.0.ebuild
+++ /dev/null
@@ -1,156 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit flag-o-matic multiprocessing python-any-r1 rust-toolchain toolchain-funcs
-
-DESCRIPTION="Rust standard library, standalone (for crossdev)"
-HOMEPAGE="https://www.rust-lang.org"
-SRC_URI="https://static.rust-lang.org/dist/rustc-${PV}-src.tar.xz"
-
-LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
-SLOT="stable/$(ver_cut 1-2)"
-# please do not keyword
-#KEYWORDS="" #nowarn
-IUSE="debug"
-
-BDEPEND="
- ${PYTHON_DEPS}
- ~dev-lang/rust-${PV}:=
-"
-
-DEPEND="||
- (
- >="${CATEGORY}"/gcc-4.7:*
- >="${CATEGORY}"/clang-3.5:*
- )
-"
-
-RDEPEND="${DEPEND}"
-
-# need full compiler to run tests
-RESTRICT="test"
-
-QA_FLAGS_IGNORED="usr/lib/rust/${PV}/rustlib/.*/lib/lib.*.so"
-
-S="${WORKDIR}/${P/-std/c}-src"
-
-PATCHES=( "${FILESDIR}"/1.51.0-bootstrap-panic.patch )
-
-#
-# The cross magic
-#
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-is_cross() {
- [[ ${CHOST} != ${CTARGET} ]]
-}
-
-toml_usex() {
- usex "$1" true false
-}
-
-pkg_pretend() {
- is_cross || die "${PN} should only be used for cross"
-}
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- default
-}
-
-src_configure() {
- # do the great cleanup
- strip-flags
- filter-flags '-mcpu=*' '-march=*' '-mtune=*' '-m32' '-m64'
- strip-unsupported-flags
-
- local rust_root x
- rust_root="$(rustc --print sysroot)"
- rtarget="$(rust_abi ${CTARGET})"
- rtarget="${ERUST_STD_RTARGET:-${rtarget}}" # some targets need to be custom.
- rbuild="$(rust_abi ${CBUILD})"
- rhost="$(rust_abi ${CHOST})"
-
- echo
- for x in CATEGORY rust_root rbuild rhost rtarget RUSTFLAGS CFLAGS CXXFLAGS LDFLAGS; do
- einfo "$(printf '%10s' ${x^^}:) ${!x}"
- done
-
- cat <<- EOF > "${S}"/config.toml
- [build]
- build = "${rbuild}"
- host = ["${rhost}"]
- target = ["${rtarget}"]
- cargo = "${rust_root}/bin/cargo"
- rustc = "${rust_root}/bin/rustc"
- submodules = false
- python = "${EPYTHON}"
- locked-deps = true
- vendor = true
- extended = true
- verbose = 2
- cargo-native-static = false
- [install]
- prefix = "${EPREFIX}/usr/lib/${PN}/${PV}"
- sysconfdir = "etc"
- docdir = "share/doc/rust"
- bindir = "bin"
- libdir = "lib"
- mandir = "share/man"
- [rust]
- # https://github.com/rust-lang/rust/issues/54872
- codegen-units-std = 1
- optimize = true
- debug = $(toml_usex debug)
- debug-assertions = $(toml_usex debug)
- debuginfo-level-rustc = 0
- backtrace = true
- incremental = false
- default-linker = "$(tc-getCC)"
- rpath = false
- dist-src = false
- remap-debuginfo = true
- jemalloc = false
- [dist]
- src-tarball = false
- [target.${rtarget}]
- cc = "$(tc-getCC ${CTARGET})"
- cxx = "$(tc-getCXX ${CTARGET})"
- linker = "$(tc-getCC ${CTARGET})"
- ar = "$(tc-getAR ${CTARGET})"
- $(usex elibc_musl 'crt-static = false' '')
- EOF
-
- einfo "${PN^} configured with the following settings:"
- cat "${S}"/config.toml || die
-}
-
-src_compile() {
- env RUST_BACKTRACE=1 \
- "${EPYTHON}" ./x.py build -vv --config="${S}"/config.toml -j$(makeopts_jobs) \
- library/std --stage 0 || die
-}
-
-src_test() {
- ewarn "${PN} can't run tests"
-}
-
-src_install() {
- local rustlib="lib/rust/${PV}/lib/rustlib"
- dodir "/usr/${rustlib}"
- pushd "build/${rhost}/stage0-sysroot/lib/rustlib" > /dev/null || die
- cp -pPRv "${rtarget}" "${ED}/usr/${rustlib}" || die
- popd > /dev/null || die
-}
diff --git a/sys-devel/rust-std/rust-std-1.52.1.ebuild b/sys-devel/rust-std/rust-std-1.52.1.ebuild
deleted file mode 100644
index 7ca481644a6a..000000000000
--- a/sys-devel/rust-std/rust-std-1.52.1.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit flag-o-matic multiprocessing python-any-r1 rust-toolchain toolchain-funcs
-
-DESCRIPTION="Rust standard library, standalone (for crossdev)"
-HOMEPAGE="https://www.rust-lang.org"
-SRC_URI="https://static.rust-lang.org/dist/rustc-${PV}-src.tar.xz"
-
-LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
-SLOT="stable/$(ver_cut 1-2)"
-# please do not keyword
-#KEYWORDS="" #nowarn
-IUSE="debug"
-
-BDEPEND="
- ${PYTHON_DEPS}
- ~dev-lang/rust-${PV}:=
-"
-
-DEPEND="||
- (
- >="${CATEGORY}"/gcc-4.7:*
- >="${CATEGORY}"/clang-3.5:*
- )
-"
-
-RDEPEND="${DEPEND}"
-
-# need full compiler to run tests
-RESTRICT="test"
-
-QA_FLAGS_IGNORED="usr/lib/rust/${PV}/rustlib/.*/lib/lib.*.so"
-
-S="${WORKDIR}/${P/-std/c}-src"
-
-#
-# The cross magic
-#
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-is_cross() {
- [[ ${CHOST} != ${CTARGET} ]]
-}
-
-toml_usex() {
- usex "$1" true false
-}
-
-pkg_pretend() {
- is_cross || die "${PN} should only be used for cross"
-}
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- default
-}
-
-src_configure() {
- # do the great cleanup
- strip-flags
- filter-flags '-mcpu=*' '-march=*' '-mtune=*' '-m32' '-m64'
- strip-unsupported-flags
-
- local rust_root x
- rust_root="$(rustc --print sysroot)"
- rtarget="$(rust_abi ${CTARGET})"
- rtarget="${ERUST_STD_RTARGET:-${rtarget}}" # some targets need to be custom.
- rbuild="$(rust_abi ${CBUILD})"
- rhost="$(rust_abi ${CHOST})"
-
- echo
- for x in CATEGORY rust_root rbuild rhost rtarget RUSTFLAGS CFLAGS CXXFLAGS LDFLAGS; do
- einfo "$(printf '%10s' ${x^^}:) ${!x}"
- done
-
- cat <<- EOF > "${S}"/config.toml
- [build]
- build = "${rbuild}"
- host = ["${rhost}"]
- target = ["${rtarget}"]
- cargo = "${rust_root}/bin/cargo"
- rustc = "${rust_root}/bin/rustc"
- submodules = false
- python = "${EPYTHON}"
- locked-deps = true
- vendor = true
- extended = true
- verbose = 2
- cargo-native-static = false
- [install]
- prefix = "${EPREFIX}/usr/lib/${PN}/${PV}"
- sysconfdir = "etc"
- docdir = "share/doc/rust"
- bindir = "bin"
- libdir = "lib"
- mandir = "share/man"
- [rust]
- # https://github.com/rust-lang/rust/issues/54872
- codegen-units-std = 1
- optimize = true
- debug = $(toml_usex debug)
- debug-assertions = $(toml_usex debug)
- debuginfo-level-rustc = 0
- backtrace = true
- incremental = false
- default-linker = "$(tc-getCC)"
- rpath = false
- dist-src = false
- remap-debuginfo = true
- jemalloc = false
- [dist]
- src-tarball = false
- [target.${rtarget}]
- cc = "$(tc-getCC ${CTARGET})"
- cxx = "$(tc-getCXX ${CTARGET})"
- linker = "$(tc-getCC ${CTARGET})"
- ar = "$(tc-getAR ${CTARGET})"
- $(usex elibc_musl 'crt-static = false' '')
- EOF
-
- einfo "${PN^} configured with the following settings:"
- cat "${S}"/config.toml || die
-}
-
-src_compile() {
- env RUST_BACKTRACE=1 \
- "${EPYTHON}" ./x.py build -vv --config="${S}"/config.toml -j$(makeopts_jobs) \
- library/std --stage 0 || die
-}
-
-src_test() {
- ewarn "${PN} can't run tests"
-}
-
-src_install() {
- local rustlib="lib/rust/${PV}/lib/rustlib"
- dodir "/usr/${rustlib}"
- pushd "build/${rhost}/stage0-sysroot/lib/rustlib" > /dev/null || die
- cp -pPRv "${rtarget}" "${ED}/usr/${rustlib}" || die
- popd > /dev/null || die
-}