summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-08 12:03:26 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-08 12:25:23 +0100
commit158e4b715bde0f48c4bb3dd9dd9a45411f8dcb53 (patch)
tree3bac9f31a603dd2a11220e84b660a5ee6692021f /sys-devel/sparse
parentdev-libs/keystone: Remove versions requiring LLVM 10 (diff)
downloadgentoo-158e4b715bde0f48c4bb3dd9dd9a45411f8dcb53.tar.gz
gentoo-158e4b715bde0f48c4bb3dd9dd9a45411f8dcb53.tar.bz2
gentoo-158e4b715bde0f48c4bb3dd9dd9a45411f8dcb53.zip
sys-devel/sparse: Remove versions requiring LLVM 10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/sparse')
-rw-r--r--sys-devel/sparse/Manifest1
-rw-r--r--sys-devel/sparse/sparse-0.6.3.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/sys-devel/sparse/Manifest b/sys-devel/sparse/Manifest
index 7c1cf179d14e..283b98fc1480 100644
--- a/sys-devel/sparse/Manifest
+++ b/sys-devel/sparse/Manifest
@@ -1,2 +1 @@
-DIST sparse-0.6.3.tar.xz 350676 BLAKE2B 5c8f54f3b7d2095df30b9a59a151e307ebedac5dbb6910ab5684b298c2b427e55dd43697e698fd289fb0d8e824ba4d72c2761772babb9f438e622f439ab3448d SHA512 33170065ea5967d7c640a7551acc78d7efee9f7aa6a9edf6afe2cdd8a04ea5cebe7b5dcdeebf791d384542b8bcdd4e818c75e7ae2e7aa4e1edbd56b68367b28f
DIST sparse-0.6.4.tar.xz 370840 BLAKE2B 4b21d26c87df65f08928438c311582a45f4cbbb5ed2bb399c3521d1e40630006d794b4f1e545693e82225f086968cf686c5bfb29059644a31812120f07caebe2 SHA512 4ada31e588469d15862579dd7eb926ce1ad717bf96d38d425b9153f2efe73949fdda5bc59d05d926614a08d70e656e4ff531a5f0a1cf8e7725c596dcdba169f9
diff --git a/sys-devel/sparse/sparse-0.6.3.ebuild b/sys-devel/sparse/sparse-0.6.3.ebuild
deleted file mode 100644
index 0c2099d4c278..000000000000
--- a/sys-devel/sparse/sparse-0.6.3.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit llvm toolchain-funcs
-
-DESCRIPTION="C semantic parser"
-HOMEPAGE="https://sparse.wiki.kernel.org/index.php/Main_Page"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://git.kernel.org/pub/scm/devel/${PN}/${PN}.git"
-else
- SRC_URI="https://www.kernel.org/pub/software/devel/${PN}/dist/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="gtk llvm sqlite test xml"
-RESTRICT="!test? ( test )"
-
-LLVM_MAX_SLOT=10
-
-RDEPEND="gtk? ( x11-libs/gtk+:2 )
- llvm? ( sys-devel/llvm:${LLVM_MAX_SLOT}= )
- sqlite? ( dev-db/sqlite:= )
- xml? ( dev-libs/libxml2 )"
-DEPEND="${RDEPEND}
- gtk? ( virtual/pkgconfig )
- xml? ( virtual/pkgconfig )"
-
-pkg_setup() {
- use llvm && llvm_pkg_setup
-}
-
-_emake() {
- # Makefile does not allow for an easy override of flags.
- # Collect them here and override default phases.
- emake \
- CC="$(tc-getCC)" \
- LD="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- CFLAGS="${CFLAGS}" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- \
- HAVE_GTK=$(usex gtk) \
- HAVE_LLVM=$(usex llvm) \
- HAVE_SQLITE=$(usex sqlite) \
- HAVE_LIBXML=$(usex xml) \
- \
- V=1 \
- PREFIX="${EPREFIX}/usr" \
- \
- "$@"
-}
-
-src_compile() {
- _emake
-}
-
-src_test() {
- _emake check
-}
-
-src_install() {
- _emake DESTDIR="${D}" install
-
- dodoc FAQ README
-}