summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-19 04:11:41 +0100
committerSam James <sam@gentoo.org>2021-09-19 04:11:41 +0100
commitf336e8bc9cb902d61882358e57531f9269c206e6 (patch)
treeee7d2a4c5cc5df382cef0c2885427b2ede46dd98 /sys-devel/sparse
parentmedia-libs/opencolorio: Keyword 2.0.1 x86, #795279 (diff)
downloadgentoo-f336e8bc9cb902d61882358e57531f9269c206e6.tar.gz
gentoo-f336e8bc9cb902d61882358e57531f9269c206e6.tar.bz2
gentoo-f336e8bc9cb902d61882358e57531f9269c206e6.zip
sys-devel/sparse: improve llvm_check_deps logic
Bug: https://bugs.gentoo.org/812551 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/sparse')
-rw-r--r--sys-devel/sparse/sparse-0.6.4.ebuild5
-rw-r--r--sys-devel/sparse/sparse-9999.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/sys-devel/sparse/sparse-0.6.4.ebuild b/sys-devel/sparse/sparse-0.6.4.ebuild
index 8e6b268ec5b9..6fbcc28e1552 100644
--- a/sys-devel/sparse/sparse-0.6.4.ebuild
+++ b/sys-devel/sparse/sparse-0.6.4.ebuild
@@ -31,9 +31,8 @@ BDEPEND="gtk? ( virtual/pkgconfig )
xml? ( virtual/pkgconfig )"
llvm_check_deps() {
- has_version "sys-devel/llvm:${LLVM_MAX_SLOT}" || \
- has_version "sys-devel/llvm:$((${LLVM_MAX_SLOT} - 1))" \
- has_version "sys-devel/llvm:$((${LLVM_MAX_SLOT} - 2))"
+ has_version "sys-devel/llvm:${LLVM_SLOT}" && \
+ has_version -r "sys-devel/llvm:${LLVM_SLOT}"
}
pkg_setup() {
diff --git a/sys-devel/sparse/sparse-9999.ebuild b/sys-devel/sparse/sparse-9999.ebuild
index 8e6b268ec5b9..6fbcc28e1552 100644
--- a/sys-devel/sparse/sparse-9999.ebuild
+++ b/sys-devel/sparse/sparse-9999.ebuild
@@ -31,9 +31,8 @@ BDEPEND="gtk? ( virtual/pkgconfig )
xml? ( virtual/pkgconfig )"
llvm_check_deps() {
- has_version "sys-devel/llvm:${LLVM_MAX_SLOT}" || \
- has_version "sys-devel/llvm:$((${LLVM_MAX_SLOT} - 1))" \
- has_version "sys-devel/llvm:$((${LLVM_MAX_SLOT} - 2))"
+ has_version "sys-devel/llvm:${LLVM_SLOT}" && \
+ has_version -r "sys-devel/llvm:${LLVM_SLOT}"
}
pkg_setup() {