summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-10-01 13:45:23 +0200
committerMichał Górny <mgorny@gentoo.org>2016-10-01 15:05:59 +0200
commit3eb4d59a51e8c6fe63ce5b19ba3ce68865677df6 (patch)
tree016cb657dba806fbd37d7a4bb131d1d6d06dfdfc /sys-devel
parentsys-devel/llvm: Use installed lit for tests (diff)
downloadgentoo-3eb4d59a51e8c6fe63ce5b19ba3ce68865677df6.tar.gz
gentoo-3eb4d59a51e8c6fe63ce5b19ba3ce68865677df6.tar.bz2
gentoo-3eb4d59a51e8c6fe63ce5b19ba3ce68865677df6.zip
sys-devel/clang: Use installed lit for tests
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/clang-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index c201bba2cea8..cedfc02923f9 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -38,6 +38,7 @@ RDEPEND="
# configparser-3.2 breaks the build (3.3 or none at all are fine)
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx )
+ test? ( dev-python/lit[${PYTHON_USEDEP}] )
xml? ( virtual/pkgconfig )
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
@@ -160,6 +161,9 @@ multilib_src_configure() {
)
use test && mycmakeargs+=(
-DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+ -DLIT_COMMAND="${EPREFIX}/usr/bin/lit"
+ fi
+
)
if multilib_is_native_abi; then