summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-11-11 11:38:47 +0000
committerMatthew Smith <matthew@gentoo.org>2022-11-11 11:38:47 +0000
commit7686df06a0062496207660744c9664dd4ada6cc7 (patch)
tree2c438fe7f82f7f96c2f292ca2b2954a584dff944 /sys-devel
parentsys-devel/mold: update live ebuild (diff)
downloadgentoo-7686df06a0062496207660744c9664dd4ada6cc7.tar.gz
gentoo-7686df06a0062496207660744c9664dd4ada6cc7.tar.bz2
gentoo-7686df06a0062496207660744c9664dd4ada6cc7.zip
sys-devel/mold: drop 1.4.2, 1.5.1
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/mold/Manifest2
-rw-r--r--sys-devel/mold/metadata.xml3
-rw-r--r--sys-devel/mold/mold-1.4.2.ebuild92
-rw-r--r--sys-devel/mold/mold-1.5.1.ebuild96
4 files changed, 0 insertions, 193 deletions
diff --git a/sys-devel/mold/Manifest b/sys-devel/mold/Manifest
index 9572f81c8d17..0b65d670e82d 100644
--- a/sys-devel/mold/Manifest
+++ b/sys-devel/mold/Manifest
@@ -1,3 +1 @@
-DIST mold-1.4.2.tar.gz 6287845 BLAKE2B ec429f70b92c4af5be83761893028f2324fe2086fea0e9b64f1d89884c6bc8dd34e5615178ef28ff19c36d01dafc834e6f6b9a8d701d62e360ef4e0be2f065bd SHA512 17f543969e53737818b0be563aee39feac672f93e0fd712827523232b64eccb4629f3994c5a90de50b5f761886669e0946a8d463663725e774eb7d352de1ced1
-DIST mold-1.5.1.tar.gz 8254552 BLAKE2B 1a5f8099df3cf7a6008632afed2aa106a54fa0c6628302f13586884fd1a37705a2bfc9ddc395261c04d53fe9de679b5afc7e052dcfe37894444b024670f44307 SHA512 340a45c5190ce5ba87eaa05238da7c70400bf4a2788a095935b9675593078ad76bbd95e67aa36b3ec683428724a3c6bc27c7e0a69569afce461682dc4bd16b10
DIST mold-1.6.0.tar.gz 8270834 BLAKE2B e9da062ab9871db35322cd516197e6e8172bee3a146ba32cde65976da2fb4cff0090ad62f06e25da9baed146c6defbd93d8704bd2156dcfb581ec247c45a2e12 SHA512 dcb498da95ee02a08b175861ae24f3793705671670f6f3487eebd3aab2487fd2163fc1747c9ca2fd1c3570a5f1f0bcfd7d4d91bf6a904a1ba098be6cbbe8c857
diff --git a/sys-devel/mold/metadata.xml b/sys-devel/mold/metadata.xml
index 6841ad2ee625..f8a85299d5bb 100644
--- a/sys-devel/mold/metadata.xml
+++ b/sys-devel/mold/metadata.xml
@@ -12,7 +12,4 @@
<upstream>
<remote-id type="github">rui314/mold</remote-id>
</upstream>
- <use>
- <flag name="system-tbb">Use <pkg>dev-cpp/tbb</pkg> package instead of vendored copy</flag>
- </use>
</pkgmetadata>
diff --git a/sys-devel/mold/mold-1.4.2.ebuild b/sys-devel/mold/mold-1.4.2.ebuild
deleted file mode 100644
index 1a83cf4d004e..000000000000
--- a/sys-devel/mold/mold-1.4.2.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="A Modern Linker"
-HOMEPAGE="https://github.com/rui314/mold"
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/rui314/mold.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/rui314/mold/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~riscv"
-fi
-
-# mold (AGPL-3)
-# - xxhash (BSD-2)
-# - tbb (Apache-2.0)
-LICENSE="AGPL-3 Apache-2.0 BSD-2"
-SLOT="0"
-IUSE="system-tbb"
-
-RDEPEND="
- sys-libs/zlib
- system-tbb? ( >=dev-cpp/tbb-2021.4.0:= )
- !kernel_Darwin? (
- >=dev-libs/mimalloc-2:=
- dev-libs/openssl:=
- )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- # https://bugs.gentoo.org/865837
- "${FILESDIR}"/mold-1.4.1-tbb-flags-stripping.patch
-)
-
-pkg_pretend() {
- # Requires a c++20 compiler, see #831473
- if [[ ${MERGE_TYPE} != binary ]]; then
- if tc-is-gcc && [[ $(gcc-major-version) -lt 10 ]]; then
- die "${PN} needs at least gcc 10"
- elif tc-is-clang && [[ $(clang-major-version) -lt 12 ]]; then
- die "${PN} needs at least clang 12"
- fi
- fi
-}
-
-src_prepare() {
- cmake_src_prepare
-
- # Needs unpackaged dwarfdump
- rm test/elf/{{dead,compress}-debug-sections,compressed-debug-info}.sh || die
-
- # Heavy tests, need qemu
- rm test/elf/gdb-index-{compress-output,dwarf{2,3,4,5}}.sh || die
- rm test/elf/lto-{archive,dso,gcc,llvm,version-script}.sh || die
-
- # Sandbox sadness
- rm test/elf/run.sh || die
- sed -i 's|`pwd`/mold-wrapper.so|"& ${LD_PRELOAD}"|' \
- test/elf/mold-wrapper{,2}.sh || die
-
- # static-pie tests require glibc built with static-pie support
- if ! has_version -d 'sys-libs/glibc[static-pie(+)]'; then
- rm test/elf/{,ifunc-}static-pie.sh || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DMOLD_ENABLE_QEMU_TESTS=OFF
- -DMOLD_LTO=OFF # Should be up to the user to decide this with CXXFLAGS.
- -DMOLD_USE_SYSTEM_MIMALLOC=ON
- -DMOLD_USE_SYSTEM_TBB=$(usex system-tbb)
- )
- cmake_src_configure
-}
-
-src_install() {
- dobin "${BUILD_DIR}"/${PN}
- dolib.so "${BUILD_DIR}"/${PN}-wrapper.so
-
- dodoc docs/{design,execstack}.md
- doman docs/${PN}.1
-
- dosym ${PN} /usr/bin/ld.${PN}
- dosym ${PN} /usr/bin/ld64.${PN}
- dosym ../../../usr/bin/${PN} /usr/libexec/${PN}/ld
-}
diff --git a/sys-devel/mold/mold-1.5.1.ebuild b/sys-devel/mold/mold-1.5.1.ebuild
deleted file mode 100644
index 34d7e10e3bf1..000000000000
--- a/sys-devel/mold/mold-1.5.1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="A Modern Linker"
-HOMEPAGE="https://github.com/rui314/mold"
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/rui314/mold.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/rui314/mold/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~riscv"
-fi
-
-# mold (AGPL-3)
-# - xxhash (BSD-2)
-# - tbb (Apache-2.0)
-LICENSE="AGPL-3 Apache-2.0 BSD-2"
-SLOT="0"
-IUSE="system-tbb"
-
-RDEPEND="
- app-arch/zstd:=
- sys-libs/zlib
- system-tbb? ( >=dev-cpp/tbb-2021.4.0:= )
- !kernel_Darwin? (
- >=dev-libs/mimalloc-2:=
- dev-libs/openssl:=
- )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- # https://bugs.gentoo.org/865837
- "${FILESDIR}"/mold-1.4.1-tbb-flags-stripping.patch
-)
-
-pkg_pretend() {
- # Requires a c++20 compiler, see #831473
- if [[ ${MERGE_TYPE} != binary ]]; then
- if tc-is-gcc && [[ $(gcc-major-version) -lt 10 ]]; then
- die "${PN} needs at least gcc 10"
- elif tc-is-clang && [[ $(clang-major-version) -lt 12 ]]; then
- die "${PN} needs at least clang 12"
- fi
- fi
-}
-
-src_prepare() {
- cmake_src_prepare
-
- # Needs unpackaged dwarfdump
- rm test/elf/{{dead,compress}-debug-sections,compressed-debug-info}.sh || die
-
- # Heavy tests, need qemu
- rm test/elf/gdb-index-{compress-output,dwarf{2,3,4,5}}.sh || die
- rm test/elf/lto-{archive,dso,gcc,llvm,version-script}.sh || die
-
- # Sandbox sadness
- rm test/elf/run.sh || die
- sed -i 's|`pwd`/mold-wrapper.so|"& ${LD_PRELOAD}"|' \
- test/elf/mold-wrapper{,2}.sh || die
-
- # static-pie tests require glibc built with static-pie support
- if ! has_version -d 'sys-libs/glibc[static-pie(+)]'; then
- rm test/elf/{,ifunc-}static-pie.sh || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DMOLD_ENABLE_QEMU_TESTS=OFF
- -DMOLD_LTO=OFF # Should be up to the user to decide this with CXXFLAGS.
- -DMOLD_USE_SYSTEM_MIMALLOC=ON
- -DMOLD_USE_SYSTEM_TBB=$(usex system-tbb)
- )
- cmake_src_configure
-}
-
-src_install() {
- dobin "${BUILD_DIR}"/${PN}
-
- # https://bugs.gentoo.org/872773
- insinto /usr/$(get_libdir)/mold
- doins "${BUILD_DIR}"/${PN}-wrapper.so
-
- dodoc docs/{design,execstack}.md
- doman docs/${PN}.1
-
- dosym ${PN} /usr/bin/ld.${PN}
- dosym ${PN} /usr/bin/ld64.${PN}
- dosym ../../../usr/bin/${PN} /usr/libexec/${PN}/ld
-}