summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-25 01:32:33 +0100
committerSam James <sam@gentoo.org>2022-05-26 06:48:02 +0100
commit7fd549fdbb59bca06cce166c20419d9efffbd85f (patch)
tree81872eb86af297187fd76be6f60a7114f05143b8 /sys-devel
parentgui-wm/sway: forward ~loong (diff)
downloadgentoo-7fd549fdbb59bca06cce166c20419d9efffbd85f.tar.gz
gentoo-7fd549fdbb59bca06cce166c20419d9efffbd85f.tar.bz2
gentoo-7fd549fdbb59bca06cce166c20419d9efffbd85f.zip
sys-devel/binutils: use econf; sync from live
1. Sync more with binutils-libs by using econf instead of raw ./configure call; means we benefit from some of the default arguments it passes, in particular thinking of silent rules which upstream are starting to support more now too (and enable by default) which econf disables. Also, we use it fine in binutils-libs w/o issue. 2. Pick up changes from live ebuild. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/binutils-9999.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/sys-devel/binutils/binutils-9999.ebuild b/sys-devel/binutils/binutils-9999.ebuild
index 10b90a94daee..b317d8ffcd0f 100644
--- a/sys-devel/binutils/binutils-9999.ebuild
+++ b/sys-devel/binutils/binutils-9999.ebuild
@@ -175,7 +175,7 @@ src_configure() {
done
echo
- cd "${MY_BUILDDIR}"
+ cd "${MY_BUILDDIR}" || die
local myconf=()
if use plugins ; then
@@ -248,7 +248,6 @@ src_configure() {
--with-bugurl="$(toolchain-binutils_bugurl)"
--with-pkgversion="$(toolchain-binutils_pkgversion)"
$(use_enable static-libs static)
- ${EXTRA_ECONF}
# Disable modules that are in a combined binutils/gdb tree, bug #490566
--disable-{gdb,libdecnumber,readline,sim}
# Strip out broken static link flags.
@@ -276,8 +275,7 @@ src_configure() {
fi
fi
- echo ./configure "${myconf[@]}"
- "${S}"/configure "${myconf[@]}" || die
+ ECONF_SOURCE="${S}" econf "${myconf[@]}" || die
# Prevent makeinfo from running if doc is unset.
if ! use doc ; then