summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-29 15:23:53 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-29 16:14:59 +0100
commit80ba31b8a0a1ec42b39b98abd3e63003612afb4e (patch)
tree5ab8d3db2f3ccba4531195d3c8a3a53ba30377b1 /sys-devel
parentdev-libs/libclc: Add 18.0.0_pre20231129 snapshot (diff)
downloadgentoo-80ba31b8a0a1ec42b39b98abd3e63003612afb4e.tar.gz
gentoo-80ba31b8a0a1ec42b39b98abd3e63003612afb4e.tar.bz2
gentoo-80ba31b8a0a1ec42b39b98abd3e63003612afb4e.zip
sys-devel/clang-runtime: Add 18.0.0_pre20231129 snapshot
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-18.0.0_pre20231129.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-18.0.0_pre20231129.ebuild b/sys-devel/clang-runtime/clang-runtime-18.0.0_pre20231129.ebuild
new file mode 100644
index 000000000000..1ce7130b4264
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-18.0.0_pre20231129.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build toolchain-funcs
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="${PV%%.*}"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"
+
+pkg_pretend() {
+ if tc-is-clang; then
+ ewarn "You seem to be using clang as a system compiler. As of clang-16,"
+ ewarn "upstream has turned a few warnings that commonly occur during"
+ ewarn "configure script runs into errors by default. This causes some"
+ ewarn "configure tests to start failing, sometimes resulting in silent"
+ ewarn "breakage, missing functionality or runtime misbehavior. It is"
+ ewarn "not yet clear whether the change will remain or be reverted."
+ ewarn
+ ewarn "For more information, please see:"
+ ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
+ fi
+}