summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-01-01 16:32:10 +0100
committerFabian Groffen <grobian@gentoo.org>2021-01-01 16:32:10 +0100
commit82671ff8646c372ed9d8d6782f143b27b43ca0c8 (patch)
tree063f1a536681054ad339c2c7a777d03d64aff4c9 /sys-devel
parentsys-kernel/pf-sources: bump to 5.10-pf4 (diff)
downloadgentoo-82671ff8646c372ed9d8d6782f143b27b43ca0c8.tar.gz
gentoo-82671ff8646c372ed9d8d6782f143b27b43ca0c8.tar.bz2
gentoo-82671ff8646c372ed9d8d6782f143b27b43ca0c8.zip
sys-devel/llvm: fix usage of libc++, bug #762898
Closes: https://bugs.gentoo.org/762898 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/llvm-11.0.0.ebuild3
-rw-r--r--sys-devel/llvm/llvm-11.0.1.9999.ebuild3
-rw-r--r--sys-devel/llvm/llvm-11.0.1_rc1.ebuild3
-rw-r--r--sys-devel/llvm/llvm-11.0.1_rc2.ebuild3
-rw-r--r--sys-devel/llvm/llvm-12.0.0.9999.ebuild3
5 files changed, 10 insertions, 5 deletions
diff --git a/sys-devel/llvm/llvm-11.0.0.ebuild b/sys-devel/llvm/llvm-11.0.0.ebuild
index 332088bd5615..81c796ea85fd 100644
--- a/sys-devel/llvm/llvm-11.0.0.ebuild
+++ b/sys-devel/llvm/llvm-11.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -381,6 +381,7 @@ multilib_src_configure() {
# libraries with libstdc++ clang, and the other way around.
mycmakeargs+=(
-DLLVM_VERSION_SUFFIX="libcxx"
+ -DLLVM_ENABLE_LIBCXX=ON
)
fi
diff --git a/sys-devel/llvm/llvm-11.0.1.9999.ebuild b/sys-devel/llvm/llvm-11.0.1.9999.ebuild
index 9c6edd92398f..40ecd173e2da 100644
--- a/sys-devel/llvm/llvm-11.0.1.9999.ebuild
+++ b/sys-devel/llvm/llvm-11.0.1.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -376,6 +376,7 @@ multilib_src_configure() {
# libraries with libstdc++ clang, and the other way around.
mycmakeargs+=(
-DLLVM_VERSION_SUFFIX="libcxx"
+ -DLLVM_ENABLE_LIBCXX=ON
)
fi
diff --git a/sys-devel/llvm/llvm-11.0.1_rc1.ebuild b/sys-devel/llvm/llvm-11.0.1_rc1.ebuild
index 9c6edd92398f..40ecd173e2da 100644
--- a/sys-devel/llvm/llvm-11.0.1_rc1.ebuild
+++ b/sys-devel/llvm/llvm-11.0.1_rc1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -376,6 +376,7 @@ multilib_src_configure() {
# libraries with libstdc++ clang, and the other way around.
mycmakeargs+=(
-DLLVM_VERSION_SUFFIX="libcxx"
+ -DLLVM_ENABLE_LIBCXX=ON
)
fi
diff --git a/sys-devel/llvm/llvm-11.0.1_rc2.ebuild b/sys-devel/llvm/llvm-11.0.1_rc2.ebuild
index 9c6edd92398f..40ecd173e2da 100644
--- a/sys-devel/llvm/llvm-11.0.1_rc2.ebuild
+++ b/sys-devel/llvm/llvm-11.0.1_rc2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -376,6 +376,7 @@ multilib_src_configure() {
# libraries with libstdc++ clang, and the other way around.
mycmakeargs+=(
-DLLVM_VERSION_SUFFIX="libcxx"
+ -DLLVM_ENABLE_LIBCXX=ON
)
fi
diff --git a/sys-devel/llvm/llvm-12.0.0.9999.ebuild b/sys-devel/llvm/llvm-12.0.0.9999.ebuild
index 610b92aa0fb2..d51ccdbab14b 100644
--- a/sys-devel/llvm/llvm-12.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-12.0.0.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -380,6 +380,7 @@ multilib_src_configure() {
# libraries with libstdc++ clang, and the other way around.
mycmakeargs+=(
-DLLVM_VERSION_SUFFIX="libcxx"
+ -DLLVM_ENABLE_LIBCXX=ON
)
fi