summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-28 19:14:23 +0000
committerSam James <sam@gentoo.org>2022-12-28 19:14:40 +0000
commit8f98a5aa67503ee63823e4114cce2a418aa1a7c2 (patch)
tree0d9e60f76af27d5bd250a5b78e4dfbd257104392 /sys-devel
parentsys-devel/gcc-config: add 2.9 (diff)
downloadgentoo-8f98a5aa67503ee63823e4114cce2a418aa1a7c2.tar.gz
gentoo-8f98a5aa67503ee63823e4114cce2a418aa1a7c2.tar.bz2
gentoo-8f98a5aa67503ee63823e4114cce2a418aa1a7c2.zip
sys-devel/crossdev: add 20221228
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20221228.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index b6c903c301ff..c26d337dc565 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1,2 +1,3 @@
DIST crossdev-20220909.tar.xz 29480 BLAKE2B 9c3ef9d9b8f13c81f9d2e21f8914158c04035a105ee1ac90ba30cb23a69744c9c6959bbcfd2e50d29144fc79937e5e585054d2eedfb2ced65a88467e509243be SHA512 86e8900a13095b7b12b00d739d28e2921f98818cd62daccfe6d750ce02113d0ef2d5e470b500bbfb80a9cf8f05b2a13882ac9963c3f1a4e1b7454bc1201df183
DIST crossdev-20221227.tar.xz 29548 BLAKE2B c990ca8494db59e0dd5792fc0327d50424a816e2584eb1aff369185ce56c5cba00db783300d5eda709944df92da2679df792c6b090f9ebfb21dc65e63dccd779 SHA512 e5ae34234d6527f792ed30747f962afff9920cf85e449671651a9bf5726bce7b5cf4009d3be2e0965732857420de0937a5d7c78e61025e7f437d95a15cb56685
+DIST crossdev-20221228.tar.xz 29568 BLAKE2B 0458a338a872a27058240c816abfcf9116703d18b687da0050213f834d5aba5df87552e16999fca7d0340aab5b8738ee0edb6ccfb656579b99f20357c077e326 SHA512 16d9d72f74c3b0d6c587c16eb8bea405c7c8eb3effc59fac55027d02348db2e10aacd9098b6f42479574a014783022737325acfaf63031e430fdf90391fa574b
diff --git a/sys-devel/crossdev/crossdev-20221228.ebuild b/sys-devel/crossdev/crossdev-20221228.ebuild
new file mode 100644
index 000000000000..a3a84da996ad
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20221228.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/crossdev.git"
+else
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Crossdev"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=sys-apps/portage-2.1
+ app-shells/bash
+ sys-apps/gentoo-functions
+"
+BDEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ ${PV} == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}