summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-06-18 20:24:40 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-06-18 20:24:54 +0100
commit9fcc12201af68e32d65371582e1e45b058a3fb82 (patch)
treebdf979f129889510d6a9f086cf5a9315113fe130 /sys-devel
parentdev-perl/Class-Method-Modifiers: Bump to version 2.130.0 (diff)
downloadgentoo-9fcc12201af68e32d65371582e1e45b058a3fb82.tar.gz
gentoo-9fcc12201af68e32d65371582e1e45b058a3fb82.tar.bz2
gentoo-9fcc12201af68e32d65371582e1e45b058a3fb82.zip
sys-devel/binutils: add USE=vanilla to skip live patches
Sometimes Gentoo patches get stale and fail to apply to binutils from head. Allow users to opt out. Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/binutils-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-devel/binutils/binutils-9999.ebuild b/sys-devel/binutils/binutils-9999.ebuild
index 7e5b921ee5f7..4cb22a0c7fcf 100644
--- a/sys-devel/binutils/binutils-9999.ebuild
+++ b/sys-devel/binutils/binutils-9999.ebuild
@@ -8,7 +8,7 @@ inherit eutils libtool flag-o-matic gnuconfig multilib toolchain-funcs
DESCRIPTION="Tools necessary to build programs"
HOMEPAGE="https://sourceware.org/binutils/"
LICENSE="GPL-3+"
-IUSE="default-gold doc +gold multitarget +nls +plugins static-libs test"
+IUSE="default-gold doc +gold multitarget +nls +plugins static-libs test vanilla"
REQUIRED_USE="default-gold? ( gold )"
# Variables that can be set here:
@@ -101,8 +101,10 @@ src_unpack() {
src_prepare() {
if [[ ! -z ${PATCH_VER} ]] ; then
- einfo "Applying binutils-${PATCH_BINUTILS_VER} patchset ${PATCH_VER}"
- eapply "${WORKDIR}/patch"/*.patch
+ if ! use vanilla; then
+ einfo "Applying binutils-${PATCH_BINUTILS_VER} patchset ${PATCH_VER}"
+ eapply "${WORKDIR}/patch"/*.patch
+ fi
fi
# This check should probably go somewhere else, like pkg_pretend.