summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-28 10:00:52 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-28 10:02:28 +0100
commita2fcc7aa353e3733a7392c4ea98b76bb80c57642 (patch)
treeb2c0af3c24fb179e0a9e5b051003a1b13a19e43d /sys-devel
parentdev-ml/llvm-ocaml: Add 13.x live ebuild (diff)
downloadgentoo-a2fcc7aa353e3733a7392c4ea98b76bb80c57642.tar.gz
gentoo-a2fcc7aa353e3733a7392c4ea98b76bb80c57642.tar.bz2
gentoo-a2fcc7aa353e3733a7392c4ea98b76bb80c57642.zip
sys-devel/clang-common: Add 13.x live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-13.0.0.9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-13.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-13.0.0.9999.ebuild
new file mode 100644
index 000000000000..03e4441b91b9
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-13.0.0.9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+S=${WORKDIR}/clang/utils
+
+src_install() {
+ newbashcomp bash-autocomplete.sh clang
+}