summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-06-22 20:08:34 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-06-22 20:21:46 +0200
commitabfa31f3d0796c3f7c9f8da123596173c4d78c2e (patch)
tree7b1970d0c175282c990e0d2ca9c17b40414c7782 /sys-devel
parentsys-apps/file: Drop old (diff)
downloadgentoo-abfa31f3d0796c3f7c9f8da123596173c4d78c2e.tar.gz
gentoo-abfa31f3d0796c3f7c9f8da123596173c4d78c2e.tar.bz2
gentoo-abfa31f3d0796c3f7c9f8da123596173c4d78c2e.zip
sys-devel/binutils: Use 9999 instead of git as live designator, add patchset
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/Manifest1
-rw-r--r--sys-devel/binutils/binutils-9999.ebuild37
2 files changed, 20 insertions, 18 deletions
diff --git a/sys-devel/binutils/Manifest b/sys-devel/binutils/Manifest
index 68339b6c103e..de8b3b1b3d30 100644
--- a/sys-devel/binutils/Manifest
+++ b/sys-devel/binutils/Manifest
@@ -11,3 +11,4 @@ DIST binutils-2.29.1.tar.bz2 29123355 BLAKE2B 83de518a27bae0f13c57b1979493dd7f7c
DIST binutils-2.30-patches-2.tar.xz 490272 BLAKE2B a28a5b5bb8faa33fec269f2c69d6ed0e4e7d5a9169861aa4b3c45511794e1e749c216862a8258c2029f1b40c511dcb2a0aeaecda57e75d52418f10d6f345718f SHA512 1686d5b58ee968f2000647acab2bee4c263d1c85fd43fed8c820fccfc0d7024a01211e7853cd5ce452fa90da500bc17309edf6dbc901c7fd6fc7b3e3d6f42581
DIST binutils-2.30-patches-3.tar.xz 548804 BLAKE2B 428a1750233ae3f019e20cb5ed1d8e6fe6455181e8f5961dbfe7b66493d1c42050f889e45c02c1fc1a84d545c9e61f81ad6ffd5afc0b1099a702ccc7637c3abe SHA512 c91e902d1d9fc2e9782df04c93173c3207c771f1c063e2ff12c9336593c954ea3f1b2474a8fc045927d72fe18f7401874059599d100c4a1fd152081f05913d03
DIST binutils-2.30.tar.xz 20286700 BLAKE2B 2dd5436a15a601011a1950e6082ec00082f5916fb82ce95ceab424fd8dc19f6daa7ac32a149f222ccdcc603354165cc206fde070eaa44fe2cc5e57486efc7868 SHA512 e747ea20d8d79fcd21b9d9f6695059caa7189d60f19256da398e34b789fea9a133c32b192e9693b5828d27683739b0198431bf8b3e39fb3b04884cf89d9aa839
+DIST binutils-9999-patches-1.tar.xz 10116 BLAKE2B 1ae970fd13ea1b94f554ed5b3fde4b6bdd90efcfc2488efc2f1465511279027c2e7f2a7371069afadb91bf833680a24e1a5df50d3169c9ee132c933b3c1fdba9 SHA512 a5d97d7070b876bf072db2a99a2876c239e03409849b9c93467bd3e70cd97c468110031a09e1c182c05d48004ec3e1651f44a1850b0275a385c3bae598cd98d7
diff --git a/sys-devel/binutils/binutils-9999.ebuild b/sys-devel/binutils/binutils-9999.ebuild
index d7ba7c31aa75..c7972aa0b704 100644
--- a/sys-devel/binutils/binutils-9999.ebuild
+++ b/sys-devel/binutils/binutils-9999.ebuild
@@ -19,25 +19,25 @@ IUSE="+cxx doc multitarget +nls static-libs test"
# for the patchsets
# Default: dilfridge :)
+PATCH_VER=1
+
case ${PV} in
9999)
- BVER="git"
EGIT_REPO_URI="https://sourceware.org/git/binutils-gdb.git"
inherit git-r3
S=${WORKDIR}/binutils
EGIT_CHECKOUT_DIR=${S}
;;
*)
- BVER=${PV}
- SRC_URI="mirror://gnu/binutils/binutils-${BVER}.tar.xz"
+ SRC_URI="mirror://gnu/binutils/binutils-${PV}.tar.xz"
;;
esac
-SLOT="${BVER}"
+SLOT="${PV}"
#
# The Gentoo patchset
#
-PATCH_BINUTILS_VER=${PATCH_BINUTILS_VER:-${BVER}}
+PATCH_BINUTILS_VER=${PATCH_BINUTILS_VER:-${PV}}
PATCH_DEV=${PATCH_DEV:-dilfridge}
[[ -z ${PATCH_VER} ]] || SRC_URI="${SRC_URI}
@@ -80,7 +80,8 @@ MY_BUILDDIR=${WORKDIR}/build
src_unpack() {
case ${PV} in
9999)
- git-r3_src_unpack;
+ git-r3_src_unpack
+ default
;;
*)
default
@@ -136,21 +137,21 @@ toolchain-binutils_bugurl() {
printf "https://bugs.gentoo.org/"
}
toolchain-binutils_pkgversion() {
- printf "Gentoo ${BVER}"
+ printf "Gentoo ${PV}"
[[ -n ${PATCH_VER} ]] && printf " p${PATCH_VER}"
}
src_configure() {
# Setup some paths
- LIBPATH=/usr/$(get_libdir)/binutils/${CTARGET}/${BVER}
+ LIBPATH=/usr/$(get_libdir)/binutils/${CTARGET}/${PV}
INCPATH=${LIBPATH}/include
- DATAPATH=/usr/share/binutils-data/${CTARGET}/${BVER}
+ DATAPATH=/usr/share/binutils-data/${CTARGET}/${PV}
if is_cross ; then
TOOLPATH=/usr/${CHOST}/${CTARGET}
else
TOOLPATH=/usr/${CTARGET}
fi
- BINPATH=${TOOLPATH}/binutils-bin/${BVER}
+ BINPATH=${TOOLPATH}/binutils-bin/${PV}
# Make sure we filter $LINGUAS so that only ones that
# actually work make it through #42033
@@ -282,7 +283,7 @@ src_install() {
# Newer versions of binutils get fancy with ${LIBPATH} #171905
cd "${ED}"/${LIBPATH}
for d in ../* ; do
- [[ ${d} == ../${BVER} ]] && continue
+ [[ ${d} == ../${PV} ]] && continue
mv ${d}/* . || die
rmdir ${d} || die
done
@@ -323,10 +324,10 @@ src_install() {
insinto /etc/env.d/binutils
cat <<-EOF > "${T}"/env.d
TARGET="${CTARGET}"
- VER="${BVER}"
+ VER="${PV}"
LIBPATH="${EPREFIX}${LIBPATH}"
EOF
- newins "${T}"/env.d ${CTARGET}-${BVER}
+ newins "${T}"/env.d ${CTARGET}-${PV}
# Handle documentation
if ! is_cross ; then
@@ -358,7 +359,7 @@ src_install() {
pkg_postinst() {
# Make sure this ${CTARGET} has a binutils version selected
[[ -e ${EROOT}/etc/env.d/binutils/config-${CTARGET} ]] && return 0
- binutils-config ${CTARGET}-${BVER}
+ binutils-config ${CTARGET}-${PV}
}
pkg_postrm() {
@@ -370,7 +371,7 @@ pkg_postrm() {
# rerun binutils-config if this is a remerge, as
# we want the mtimes on the symlinks updated (if
# it is the same as the current selected profile)
- if [[ ! -e ${EPREFIX}${BINPATH}/ld ]] && [[ ${current_profile} == ${CTARGET}-${BVER} ]] ; then
+ if [[ ! -e ${EPREFIX}${BINPATH}/ld ]] && [[ ${current_profile} == ${CTARGET}-${PV} ]] ; then
local choice=$(binutils-config -l | grep ${CTARGET} | awk '{print $2}')
choice=${choice//$'\n'/ }
choice=${choice/* }
@@ -379,8 +380,8 @@ pkg_postrm() {
else
binutils-config ${choice}
fi
- elif [[ $(CHOST=${CTARGET} binutils-config -c) == ${CTARGET}-${BVER} ]] ; then
- binutils-config ${CTARGET}-${BVER}
+ elif [[ $(CHOST=${CTARGET} binutils-config -c) == ${CTARGET}-${PV} ]] ; then
+ binutils-config ${CTARGET}-${PV}
fi
}
@@ -410,4 +411,4 @@ pkg_postrm() {
# - at build-time set scriptdir to point to symlinked location:
# ${TOOLPATH}: /usr/${CHOST} (or /usr/${CHOST}/${CTARGET} for cross-case)
# - at install-time set scriptdir to point to slotted location:
-# ${LIBPATH}: /usr/$(get_libdir)/binutils/${CTARGET}/${BVER}
+# ${LIBPATH}: /usr/$(get_libdir)/binutils/${CTARGET}/${PV}