summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-12-04 08:54:22 +0000
committerMatthew Smith <matthew@gentoo.org>2022-12-04 08:55:22 +0000
commitb0bd2023758303844007687ca0f568a2bd2df4ad (patch)
tree9d3aed9891f2a166e66aaecf2c58cc0bd44a68e5 /sys-devel
parentnet-misc/putty: drop 0.77-r3 (diff)
downloadgentoo-b0bd2023758303844007687ca0f568a2bd2df4ad.tar.gz
gentoo-b0bd2023758303844007687ca0f568a2bd2df4ad.tar.bz2
gentoo-b0bd2023758303844007687ca0f568a2bd2df4ad.zip
sys-devel/mold: drop 1.6.0-r1
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/mold/Manifest1
-rw-r--r--sys-devel/mold/files/mold-1.4.1-tbb-flags-stripping.patch28
-rw-r--r--sys-devel/mold/mold-1.6.0-r1.ebuild94
3 files changed, 0 insertions, 123 deletions
diff --git a/sys-devel/mold/Manifest b/sys-devel/mold/Manifest
index 51dd654d8604..d00b1f11c936 100644
--- a/sys-devel/mold/Manifest
+++ b/sys-devel/mold/Manifest
@@ -1,2 +1 @@
-DIST mold-1.6.0.tar.gz 8270834 BLAKE2B e9da062ab9871db35322cd516197e6e8172bee3a146ba32cde65976da2fb4cff0090ad62f06e25da9baed146c6defbd93d8704bd2156dcfb581ec247c45a2e12 SHA512 dcb498da95ee02a08b175861ae24f3793705671670f6f3487eebd3aab2487fd2163fc1747c9ca2fd1c3570a5f1f0bcfd7d4d91bf6a904a1ba098be6cbbe8c857
DIST mold-1.7.1.tar.gz 8381932 BLAKE2B 3355304cfe4de7aa96608e68183868debe6d7749940c507e717c5f6def3344bf1bfba8605275506bec6bab018f921c1da87515c4a8fc4f4488d37d874e70c452 SHA512 2e1b6203591718976a3b6c22cb9cdc4037efd101ecb520b809aaa242ee758ee24ed98d0b53012fa8423725fd9b89da94e67603af57b9de1dfb3189a096e1ae5b
diff --git a/sys-devel/mold/files/mold-1.4.1-tbb-flags-stripping.patch b/sys-devel/mold/files/mold-1.4.1-tbb-flags-stripping.patch
deleted file mode 100644
index 58cfca04132e..000000000000
--- a/sys-devel/mold/files/mold-1.4.1-tbb-flags-stripping.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-https://github.com/oneapi-src/oneTBB/pull/716
-https://bugs.gentoo.org/865837
-
-From 9595b9699ae6863d1e0cf770a89728eafcaf8845 Mon Sep 17 00:00:00 2001
-From: Christoph Erhardt <github@sicherha.de>
-Date: Wed, 5 Jan 2022 15:13:32 +0100
-Subject: [PATCH] Fix overeager stripping of compile flag
-
-The existing regex strips all occurrences of the given string from
-`${CMAKE_CXX_FLAGS}`, regardless of whether it is just a substring of a
-flag. For instance, `-Werror=format-security` gets truncated to
-`=format-security`.
-
-The new regex makes sure that only whole words get replaced.
-
-Signed-off-by: Christoph Erhardt <github@sicherha.de>
---- a/third-party/tbb/cmake/utils.cmake
-+++ b/third-party/tbb/cmake/utils.cmake
-@@ -18,7 +18,7 @@ macro(tbb_remove_compile_flag flag)
- set_property(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR} PROPERTY COMPILE_OPTIONS ${_tbb_compile_options})
- unset(_tbb_compile_options)
- if (CMAKE_CXX_FLAGS)
-- string(REGEX REPLACE ${flag} "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
-+ string(REGEX REPLACE "(^|[ \t\r\n]+)${flag}($|[ \t\r\n]+)" " " CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
- endif()
- endmacro()
-
-
diff --git a/sys-devel/mold/mold-1.6.0-r1.ebuild b/sys-devel/mold/mold-1.6.0-r1.ebuild
deleted file mode 100644
index 45c7fd085eb8..000000000000
--- a/sys-devel/mold/mold-1.6.0-r1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="A Modern Linker"
-HOMEPAGE="https://github.com/rui314/mold"
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/rui314/mold.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/rui314/mold/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~riscv ~x86"
-fi
-
-# mold (AGPL-3)
-# - xxhash (BSD-2)
-LICENSE="AGPL-3 BSD-2"
-SLOT="0"
-
-RDEPEND="
- app-arch/zstd:=
- >=dev-cpp/tbb-2021.7.0:=
- sys-libs/zlib
- !kernel_Darwin? (
- >=dev-libs/mimalloc-2:=
- dev-libs/openssl:=
- )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- # https://bugs.gentoo.org/865837
- "${FILESDIR}"/mold-1.4.1-tbb-flags-stripping.patch
-)
-
-pkg_pretend() {
- # Requires a c++20 compiler, see #831473
- if [[ ${MERGE_TYPE} != binary ]]; then
- if tc-is-gcc && [[ $(gcc-major-version) -lt 10 ]]; then
- die "${PN} needs at least gcc 10"
- elif tc-is-clang && [[ $(clang-major-version) -lt 12 ]]; then
- die "${PN} needs at least clang 12"
- fi
- fi
-}
-
-src_prepare() {
- cmake_src_prepare
-
- # Needs unpackaged dwarfdump
- rm test/elf/{{dead,compress}-debug-sections,compressed-debug-info}.sh || die
-
- # Heavy tests, need qemu
- rm test/elf/gdb-index-{compress-output,dwarf{2,3,4,5}}.sh || die
- rm test/elf/lto-{archive,dso,gcc,llvm,version-script}.sh || die
-
- # Sandbox sadness
- rm test/elf/run.sh || die
- sed -i 's|`pwd`/mold-wrapper.so|"& ${LD_PRELOAD}"|' \
- test/elf/mold-wrapper{,2}.sh || die
-
- # static-pie tests require glibc built with static-pie support
- if ! has_version -d 'sys-libs/glibc[static-pie(+)]'; then
- rm test/elf/{,ifunc-}static-pie.sh || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DMOLD_ENABLE_QEMU_TESTS=OFF
- -DMOLD_LTO=OFF # Should be up to the user to decide this with CXXFLAGS.
- -DMOLD_USE_SYSTEM_MIMALLOC=ON
- -DMOLD_USE_SYSTEM_TBB=ON
- )
- cmake_src_configure
-}
-
-src_install() {
- dobin "${BUILD_DIR}"/${PN}
-
- # https://bugs.gentoo.org/872773
- insinto /usr/$(get_libdir)/mold
- doins "${BUILD_DIR}"/${PN}-wrapper.so
-
- dodoc docs/{design,execstack}.md
- doman docs/${PN}.1
-
- dosym ${PN} /usr/bin/ld.${PN}
- dosym ${PN} /usr/bin/ld64.${PN}
- dosym ../../../usr/bin/${PN} /usr/libexec/${PN}/ld
-}