summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-05-04 18:23:35 -0700
committerSam James <sam@gentoo.org>2023-05-05 05:41:42 +0100
commitb53a8bbfb7f20ca11a936818443f7080fcad5ad4 (patch)
tree17919b55b1ae7960921bcb671d08e7f766d934a5 /sys-devel
parentgui-libs/xdg-desktop-portal-wlr: add github upstream metadata (diff)
downloadgentoo-b53a8bbfb7f20ca11a936818443f7080fcad5ad4.tar.gz
gentoo-b53a8bbfb7f20ca11a936818443f7080fcad5ad4.tar.bz2
gentoo-b53a8bbfb7f20ca11a936818443f7080fcad5ad4.zip
sys-devel/slibtool: fix the build in some chroots
When building slibtool in a chroot where the SHELL is set as /sbin/nologin the sofort configure will fail. This can be worked around for now by explicitly setting the shell as /bin/sh during configure. Also fixes the libdir path and updates to EAPI=8. Closes: https://bugs.gentoo.org/905721 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/30878 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/slibtool/slibtool-0.5.34.ebuild7
-rw-r--r--sys-devel/slibtool/slibtool-9999.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/sys-devel/slibtool/slibtool-0.5.34.ebuild b/sys-devel/slibtool/slibtool-0.5.34.ebuild
index c176e886d89c..747b80b4a308 100644
--- a/sys-devel/slibtool/slibtool-0.5.34.ebuild
+++ b/sys-devel/slibtool/slibtool-0.5.34.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
@@ -32,6 +32,7 @@ src_configure() {
--compiler="$(tc-getCC)" \
--host=${CHOST} \
--prefix="${EPREFIX}"/usr \
- --libdir="$(get_libdir)" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --shell="${EPREFIX}"/bin/sh \
|| die
}
diff --git a/sys-devel/slibtool/slibtool-9999.ebuild b/sys-devel/slibtool/slibtool-9999.ebuild
index 200a19a514d4..5295be737954 100644
--- a/sys-devel/slibtool/slibtool-9999.ebuild
+++ b/sys-devel/slibtool/slibtool-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
@@ -32,6 +32,7 @@ src_configure() {
--compiler="$(tc-getCC)" \
--host=${CHOST} \
--prefix="${EPREFIX}"/usr \
- --libdir="$(get_libdir)" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --shell="${EPREFIX}"/bin/sh \
|| die
}