summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-10-22 18:14:39 +0300
committerSergey Popov <pinkbyte@gentoo.org>2015-10-22 18:17:29 +0300
commitb64eb2f7af96867a39670527daa6aaaa37bc05e2 (patch)
tree33d00e7a1f7206bc279c0187a0f5547f2da7b179 /sys-devel
parentsys-devel/distcc: fix path to make.conf in pkg_postinst tips section (diff)
downloadgentoo-b64eb2f7af96867a39670527daa6aaaa37bc05e2.tar.gz
gentoo-b64eb2f7af96867a39670527daa6aaaa37bc05e2.tar.bz2
gentoo-b64eb2f7af96867a39670527daa6aaaa37bc05e2.zip
sys-devel/distcc: revision bump
Distcc-config appears to be installed twice, which is wrong. Also, create separate subdirectory for config files and initscripts, related to 3.2 branch of package. Drop old revision. Gentoo-Bug: 523658 Package-Manager: portage-2.2.20
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/distcc/distcc-3.2_rc1-r4.ebuild (renamed from sys-devel/distcc/distcc-3.2_rc1-r3.ebuild)8
-rw-r--r--sys-devel/distcc/files/3.2/conf40
-rw-r--r--sys-devel/distcc/files/3.2/distcc-config (renamed from sys-devel/distcc/files/distcc-config-3.2_rc1)0
-rw-r--r--sys-devel/distcc/files/3.2/init32
4 files changed, 75 insertions, 5 deletions
diff --git a/sys-devel/distcc/distcc-3.2_rc1-r3.ebuild b/sys-devel/distcc/distcc-3.2_rc1-r4.ebuild
index 29e2e0fc9b94..5dbdc1693d46 100644
--- a/sys-devel/distcc/distcc-3.2_rc1-r3.ebuild
+++ b/sys-devel/distcc/distcc-3.2_rc1-r4.ebuild
@@ -76,7 +76,7 @@ src_prepare() {
sed \
-e "s:@EPREFIX@:${EPREFIX:-/}:" \
-e "s:@libdir@:/usr/$(get_libdir):" \
- "${FILESDIR}/distcc-config-3.2_rc1" > "${T}/distcc-config" || die
+ "${FILESDIR}/3.2/distcc-config" > "${T}/distcc-config" || die
eaclocal -Im4 --output=aclocal.m4
eautoconf
@@ -102,13 +102,11 @@ src_install() {
default
python_optimize
- dobin "${FILESDIR}/3.0/distcc-config"
-
- newinitd "${FILESDIR}/3.1/init" distccd
+ newinitd "${FILESDIR}/3.2/init" distccd
systemd_dounit "${FILESDIR}/distccd.service"
systemd_install_serviced "${FILESDIR}/distccd.service.conf"
- cp "${FILESDIR}/3.0/conf" "${T}/distccd" || die
+ cp "${FILESDIR}/3.2/conf" "${T}/distccd" || die
if use avahi; then
cat >> "${T}/distccd" <<-EOF
diff --git a/sys-devel/distcc/files/3.2/conf b/sys-devel/distcc/files/3.2/conf
new file mode 100644
index 000000000000..c499271685e9
--- /dev/null
+++ b/sys-devel/distcc/files/3.2/conf
@@ -0,0 +1,40 @@
+# /etc/conf.d/distccd: config file for /etc/init.d/distccd
+
+DISTCCD_OPTS=""
+
+# this is the distccd executable
+DISTCCD_EXEC="/usr/bin/distccd"
+
+# this is where distccd will store its pid file
+DISTCCD_PIDFILE="/var/run/distccd/distccd.pid"
+
+# set this option to run distccd with extra parameters
+# Default port is 3632. For most people the default is okay.
+DISTCCD_OPTS="${DISTCCD_OPTS} --port 3632"
+
+# Logging
+# You can change some logging options here:
+# --log-file FILE
+# --log-level LEVEL [critical,error,warning, notice, info, debug]
+#
+# Leaving --log-file blank will log to syslog
+# example: --log-file /dev/null --log-level warning
+# example: --log-level critical
+
+DISTCCD_OPTS="${DISTCCD_OPTS} --log-level critical"
+
+# SECURITY NOTICE:
+# It is HIGHLY recommended that you use the --listen option
+# for increased security. You can specify an IP to permit connections
+# from or a CIDR mask
+# --listen accepts only a single IP
+# --allow is now mandatory as of distcc-2.18.
+# example: --allow 192.168.0.0/24
+# example: --allow 192.168.0.5 --allow 192.168.0.150
+# example: --listen 192.168.0.2
+DISTCCD_OPTS="${DISTCCD_OPTS} --allow 192.168.0.0/24"
+#DISTCCD_OPTS="${DISTCCD_OPTS} --listen 192.168.0.2"
+
+# set this for niceness
+# Default is 15
+DISTCCD_OPTS="${DISTCCD_OPTS} -N 15"
diff --git a/sys-devel/distcc/files/distcc-config-3.2_rc1 b/sys-devel/distcc/files/3.2/distcc-config
index 6f3bd27e40f0..6f3bd27e40f0 100644
--- a/sys-devel/distcc/files/distcc-config-3.2_rc1
+++ b/sys-devel/distcc/files/3.2/distcc-config
diff --git a/sys-devel/distcc/files/3.2/init b/sys-devel/distcc/files/3.2/init
new file mode 100644
index 000000000000..f7009f6e3101
--- /dev/null
+++ b/sys-devel/distcc/files/3.2/init
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+ use avahi-daemon ypbind
+}
+
+start() {
+ ebegin "Starting distccd"
+
+ if [ ! -e /var/run/distccd ] ; then
+ mkdir -p /var/run/distccd
+ chown distcc:daemon /var/run/distccd
+ fi
+
+ # Load PATH and GCC_SPECS from gcc-config, bug #262773
+ eval "$(gcc-config -E)"
+
+ start-stop-daemon --start --quiet --exec "${DISTCCD_EXEC}" --user distcc -- \
+ --daemon --pid-file "${DISTCCD_PIDFILE}" \
+ ${DISTCCD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping distccd"
+ start-stop-daemon --stop --quiet --pidfile "${DISTCCD_PIDFILE}"
+ eend $?
+}